Avatar of mshaikh22
mshaikh22
 asked on

Moving Exchange 2010 DAG Mailbox Server, CAS Array, blackberry server 5.02 Advice

Dear Experts,

 
I needed some advice regarding moving the exchange servers and blackberry server from one server room to another.

At the moment we have two server rooms.

Server Room A has a subnet of 10.10.10.1/24

Server Room B has a subnet of 10.0.0.1/24

Server Room B is the new server room we have acquired, we want to move all servers to that Server Room from Server Room A.

We moved Mailbox Server 3 to Room A to Room B. We had to change the ip address of the server since Server Room B does not have Server Room A,  ip ranges.


Since the move of Mailbox Server 3, The CAS array which is 10.10.10.1 ( cas1 10.10.10.2 and cas3 10.10.10.3) cannot see Mailbox Server 3 10.0.0.3.

We load balanced our dbs against both mailbox server 1 10.10.10.10 and server 10.0.0.3. But users sitting on the dbs that are on Mailbox Server 3 cannot access outlook web app.


One of the engineers said that since mailbox server 3 is not part of the same network, the cas array cannot see mailbox server 3.


This has lead us to move all of the remaining exchange , cas and blackberry servers to server room b, the 10.0.0.1 network


Now someone told me that the cas array and mailbox servers need to be on the same network for owa to work, is that correct.


I wanted to find out if this is the right move, we are making and step by steps details on how successfully carry out this move.


Thank you very much,

M
ExchangeBlackBerry ProgrammingBlackBerry

Avatar of undefined
Last Comment
mshaikh22

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Navdeep

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mshaikh22

ASKER
db1, db2 and db3 were sitting on mailbox server 1 and db4 db5 and db6 were on mailbox server 3 before the move. After moving mailbox server 3, to a different network. OWA stop working for users on db4, db5 and db6.

so we had end make all dbs on mailbox server 1 active to ensure that the user residing on db4 5 and 6 can access owa

cas array ip is 10.10.10.1
cas server 1 10.10.10.2
cas server 3 10.10.10.3

I was told by the external consultant that cas array, cas server 1 3 and mailbox server have to be on the same ip range.

SOLUTION
Navdeep

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mshaikh22

ASKER
server room a can see server room b with no issues.
do i need to move one cas server to server room b and give an ip of 10.0.0.21 to get owa working.

SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
Yes it is.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
I will run some tests this weekend and get back to you.

THanks a lot for your help V-2nas,
mshaikh22

ASKER
Hi v-2nas,

sorry getting back to you late on this. Basically, i logged in on owa using the user that resides on the database that is on mailbox server room b and I receive this message after putting the username and password on the login page

A server configuration change is temporarily preventing access to your account. Please close all Internet Explorer windows and try again in a few minutes. If the problem continues, contact your helpdesk.

One thing I notice that when I changed the ip on the mailbox server in server room b 2 weeks ago, it created it own dag network and subnet and was not part of server room A dag network.

Let assume the ip of the mailbox server is 10.68.40.10

In sites and services I noticed two thing

we add several subnet for Site A before and server b was one of them which was
10.68.40.0/24

we have a site C which has a subnet of 10.68.0.0/16

Do you think that Site C subnet. Is having any affect site A subnet.

How can we know which Mailbox server, the CAS server can see


Thanks a lot

M

.  


SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
Thanks Navdeep

Your Response:

"If servers are in different site then you need to bring them in same site for cas array to work otherwise you need to remove cas array".


Now by removing the newly replication created network 10.68.40.0 from the DAG network, and adding it back to Site A Dag in EMC, while server b is offline.
then bring server b online. Do You think that would solve the issue. what additional step I need to take to make that happen.


i know that cas arrays works per site but how does it know which mailbox server to serve.

the dag network is labelled a bit differently to the one in ad sites and services and
in ad sites and services that server b subnet is present over there.

Does it just deliver email to a mailbox server thats in the site.

Is the subnet in Site C - 10.68.0.0/16 conflicting with Site A 10.68.40.0/24

M



Thanks a lot for all of the answers






Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
I read that and unfortunately we are using a single subnet model for the dag so that why the reason might be occuring. Although, I need to understand where do the cas arrays see the mailbox servers.

but the replication of the dbs is not affected, it failover fine but only owa is affected.

So do the CAS arrays and mailbox servers need to be on the same subnet.  

By looking microsoft suggest that they need to be on the same subnet

http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/10baed82-be74-4948-8142-72f7793d1579/


M
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
Site A Server Room A - 2 servers (CAS/HT), 1 Mailbox Server   Server A subnet - 10.10.10.0/24
          Server Room B - Mailbox Server 10.69.40.0/24

Site C - 2 servers (CAS/HT)  and 1 mailbox server - 10.69.0.0/24


DAG Network displayed in EMC

Site A -
subnet - 10.10.10.0
ip - 10.10.10.10

Network02 -          (Automatically created when mailbox server ip was changed)

subnet - 10.68.40.0
ip - 10.68.40.10

Site C -
subnet - 10.65.40.0
ip - 10.65.40.10


AD Site and Services

Site A -
10.10.10.0/24
10.69.40.0/24

Site C
10.69.0.0/16
10.65.40.0/24

All network can see each other with no issues.
There a Point to Point Link between Site A and Site C.

Only thing affected is OWA. DB Replication is working fine.
Any DB acitve on Site A Server Room b mailbox server. OWA throws this when a user is logging in.

A server configuration change is temporarily preventing access to your account. Please close all Internet Explorer windows and try again in a few minutes. If the problem continues, contact your helpdesk.

Thanks  a lot

M
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mshaikh22

ASKER
hi v2nas,

I try to get a diagram for you this weekend, about removing the cas array.that would cause downtime, so i dont want to try that.

I couldnt see any event logs on the cas or the mailbiox server where should i looking for them.




This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
mshaikh22

ASKER
Sorry for getting back to you late. The issue has been resolved it was a site issue and after all the cas server and mailbox servers were moved to the same subnet. Its working now.

Thanks for your help.

M
mshaikh22

ASKER
Issue has been resolved. Thanks for the help