Lync 2010, Enabling SipServerTCPPort on 5060 not working

usmmsupport
usmmsupport used Ask the Experts™
on
We get the following error when running the command 'set-csregistrar registrar:fqdn -sipservertcpport 5060"  the current setting of this variable is null (blank) according to get-csservice -registrar.  Here is the full error :

PS C:\Users\trichert> set-csregistrar -Identity Registrar:corplync01.corp.usmmll
c.com -SipServerTcpPort 5060
Set-CsRegistrar : GruuType must have a length of at least 1.
At line:1 char:16
+ set-csregistrar <<<<  -Identity Registrar:corplync01.corp.usmmllc.com -SipSer
verTcpPort 5060
    + CategoryInfo          : InvalidArgument: (Registrar:corplync01.corp.usmm
   llc.com:String) [Set-CsRegistrar], PropertyArgumentOutOfRangeException
    + FullyQualifiedErrorId : InvalidUpdate,Microsoft.Rtc.Management.Xds.SetRe
   gistrarCmdlet
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
1st off I think you need quotes for the registrar name also I don't know if the command is SIPServerTcpPort 5060 I think it is SIPPort 5060

Try

PS C:\Users\trichert> set-csregistrar -Identity "Registrar:corplync01.corp.usmmll
c.com" -SipPort 5060

Here is a link to the Syntax
hmm.  Try the above script, but your code worked on my test server (using my pool FQDN).  Interesting.  It may still need quotes though because of the naming convention.
PS C:\Users\trichert> set-csregistrar -Identity "Registrar:corplync01.corp.usmmll
c.com" -SipServerTcpPort 5060

This may be a better options as the SipServerTCPPort fxn may be different than SipPort
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

Author

Commented:
djjack -- No, SIPPort is very different from SIPServerTcpPort

I've tried it with the " and with the -Identity, I get the same exact error.  If i change the 5060 to $false, i get "You must specify a number greater than 1" so it is parsing the command ok.
True.    I didn't see sipservertcpport in the csregistrar cmdlet list.  Where did you find it? Can it be done in the console?

Author

Commented:
NAME
    Set-CsRegistrar

SYNOPSIS
    Enables you to modify the properties of one or more Registrars. Registrars
    are used to authenticate logon requests, and to maintain information about
    user status and availability.



SYNTAX
    Set-CsRegistrar [-Identity <XdsGlobalRelativeIdentity>] [-ArchivingServer <
    String>] [-BackupRegistrar <String>] [-Confirm [<SwitchParameter>]] [-EdgeS
    erver <String>] [-EnableAutomaticFailover <$true | $false>] [-FailbackDetec
    tionInterval <TimeSpan>] [-FailureDetectionInterval <TimeSpan>] [-Force <Sw
    itchParameter>] [-MonitoringServer <String>] [-Registrar <String>] [-SipHea
    lthPort <UInt16>] [-SipPort <UInt16>] [-SipServerTcpPort <UInt16>] [-UserSe
    rver <String>] [-WebPort <UInt16>] [-WebServer <String>] [-WhatIf [<SwitchP
    arameter>]] [<CommonParameters>]


It is there ;)  I don't know if it can be done from the GUI, if it can I don't know how ..
Thanks for the training.  I have never used that cmdlet before, I had never even heard of it until you brought it up so thanks for the education.

So if you do Get-CSService does anything show up there or is it still null?
OK let's try it stepwise....

1.  Use set-csregistrar "Registrar:corplync01.corp.usmmllc.com" and see if you get an error.  That way you know, like you mentioned before, that it is parsing the cmdlet.
2.  If you don't get an error try.

set-csregistrar "Registrar:corplync01.corp.usmmllc.com" -SipServerTcpPort 5060

It may just be a syntax issue but the Gruu Type message is troublseome.  If I understand GRUU correct,it is basically a way to route information to a User Agent for SIP traffic.  If you still get that error, that wil be the next step to hurdle.

Just thinking over chat here but.....  GRUU attaches to a UA, or user agent, per device.  What if some of the devices won't take unencrytped traffic.  hmmm.  This is a good one.

Let me know how the testing of the above steps go and we can see if we can work through each part.

Author

Commented:
so if i do set-csregistrar registrar:corplync01.corp.usmmllc.com -sipport 5060 , it works and changes the sipport (i changed it back as i dont want this changed) its on when trying to do the -sipservertcpport that it errors.

Is there a way to look at the cmdlet itself to see what it is trying to do?  Is there a ps1 file somewhere with the cmdlet in it?
ok, try changing the SipServerTcpPort to another port other than 5060.  maybe there is a sharing issue?  You can always turn it off with -SipServerTcpPort $false.

Author

Commented:
nope i tried 50 different ports between 1 and 65000 they all give the same error, and in fact if i use $false i get a different error :

Set-CsRegistrar : PortValue must be greater than or equal to 1.
The reason you are getting that error is becuase the value is already null, so it is expecting a value of 1 or higher.  I still can't exaplin why you are getting the GruuType message.

I have tried to look into seeing the cmdlet itself but can't find much there.  There are ps11 files located under common files\microsoft Lync Server 2010\modules\Lync but I don't know how much help these are going to be.
man I am at a loss here.  One other thing you can check is the services ont he servers.  Go to Control Panel and Topology and make sure thos are ok.

After that the only thing I can thing of is that there is an issue somewhere else.  Are you using devices?
Commented:
This is a bug after a update: her is a workaround:
1. Export your configuration to the zip file (Export-CsConfiguration).

2. Open DocItemSet.xml

3. At the end of the below string

<Port Owner="urn:component:QoE" Usage="SipServer" InterfaceSide="Primary" InterfaceNumber="1" Port="5061" Protocol="Mtls" UrlPath="/LiveServer/QoE/" AuthorizesRequests="true" GruuType="QoS" />

Put following line

<Port Owner="urn:component:Registrar" Usage="SipServer" InterfaceSide="Primary" InterfaceNumber="1" Port="5060" Protocol="Tcp" UrlPath="/" AuthorizesRequests="false" />

4. Zip bot files again and import-csconfig.

5. Run Get-CsService -Registrar this should now show you SipServerTcpPort          : 5060  

All the syntax in the xml file is case sensitive. Hop this will help you.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial