Windows 7 Boot up slow when off domain, netlogon 5719

nmatese
nmatese used Ask the Experts™
on
Hello,

My road warrior users are having issues where their laptops take a while to startup while on the road or anywhere outside our network.  With Windows 7, It hangs at "Please Wait" for roughly 1 minute and 45 seconds. The actual login process only takes about 15 seconds.

If i turn off the wireless on the laptop with no ethernet connected it roughly takes about 45 seconds to boot up.

I realize I am getting NETLOGON 5719,is there anyway to reduce the domain controller search time? Or another way to speed up the boot process.

Thank you
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2011
Top Expert 2011

Commented:
Actually, are you using static dns entries? Might be all it is.....

Author

Commented:
No we are completely configured via DHCP
Have your users hibernate instead of shutting down their units.

Author

Commented:
I realize that is an option, but there has to be a solution for all the millions of corporate laptop users.
Sandesh DubeyTechnical Lead
Top Expert 2011

Commented:

-On the wireless network if the wireless NIC is configured to get IP from DHCP the event id 5719 can occur.The Netlogon service may start before the network is ready, the computer may be unable to locate the logon domain controller.Hence there is delay while login in domain
 
-  The Nelogon service try to starts before getting ip from the DHCP, but at this time IP is not assigned by the the DHCP and netlogon service gives error.

-  Assign static IP address to the Wireless NIC and check else connect the PC to wired network.

Author

Commented:
Static IP's wont work because the users will be floating between multiple hotel networks etc.
Sandesh DubeyTechnical Lead
Top Expert 2011

Commented:
Then this much of delay is expected in wireless network.
Try below link if it can helps
http://www.sysprobs.com/windows-7-network-slow
Ignore the 5th point in the article.
Top Expert 2011

Commented:
From this link:

Parameters\ExpectedDialupDelay

This registry location can set ADDITIONAL time, but there was no reference to reducing time.  I think you may be out of luck with any registry tweak for this.  It appears this is "by design"

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type              

REG_DWORD
      
Range 0–600 (seconds)

Default value 0

Description

Specifies the additional time that the Net Logon service waits for a response from a domain controller. If the domain controller does not respond before the total time allowed elapses, then Net Logon assumes that the domain controller is not available, and it proceeds accordingly.

Try to set "Startup policy processing wait time" in group policy.  It's located under Computer Configuration | Policies | Admin Templates | System | Group Policy.

 



Most Valuable Expert 2011
Top Expert 2011

Commented:
Are you using the "Always wait for the network" at login?

Author

Commented:
@johnb6767 I Sony have it explicitly set.

Author

Commented:
@Jim-r I have tried that within the local GOP for windows 7. No dice.
Most Valuable Expert 2011
Top Expert 2011

Commented:
???

Author

Commented:
@johnb6767 sorry iphone auto-complete got me. No i dont have Always wait for the network set.
Try to set "Startup policy processing wait time" in group policy.  It's located under Computer Configuration | Policies | Admin Templates | System | Group Policy.
Try Netmotion

Author

Commented:
More of a workaround than a fix.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial