ISAPI Filters not loading

TownTalk
TownTalk used Ask the Experts™
on
This is SBS2008 + Exchange 2007 on 64 bit hardware.

I installed this server about a year ago. At that time I had a problem with one of the websites hosted on it. That website needs to reference an Access database. But there is no 64 bit driver for access databases. So I had to enable 32 bit applications on the application pool in IIS. It's all worked ok since then.

Yesterday, I added a second website which need to reference an Access database. Again, I found that it did not work until I enabled 32bit applications on the application pool. Then it worked ok.

Unfortunately, something seems to have broken in IIS. We first noticed because OWA stopped working. When I look at the event log, I see lots of errors such as this:

ISAPI Filter 'C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture.

I disabled the new application pool and rebooted the server. The problem is still there. So what do I do now?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Please check the permisson on the 'C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll', the Authenticated Users should have Read & Execute permisson.

Author

Commented:
Yes they have Read and Execute permissions on that file. I wouldn't have expected the permission to change as a result of what I did yesterday.
Technical Manager
Top Expert 2010
Commented:
Which application pool you modified?

Author

Commented:
When I created the new website, it created a brand new application pool, and that is the pool that I enabled 32 bit applications on. But I just noticed that 32bit applications are now enabled on every application pool.

Author

Commented:
Actually that was the fix. I just went down the list and disabled 32bit applications on all except the 2 sites that need 32 bit apps. It's all working again now.

So why would 32 bit applications get enabled on every application pool, just because I enabled it on that new pool yesterday?

Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Yes, that correct.

Author

Commented:
Thanks for your help. It gave me the idea to check the 32 bit setting on the other application pools.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial