We help IT Professionals succeed at work.

How to prevent Exchange from sending NDR for Domain not found

brian_appliedcpu
brian_appliedcpu used Ask the Experts™
on
I have an exchange server that got hit by some spammer.  Not quite sure the details of how but what i ended up with was several hunderd NDR messages that could not be delivered so they sat in the queue.  They all had an error  similar to this:
Last Error: 450 4.1.2 <sade@ms1.ibtpe.com.tw>: Recipient address rejected: Domain not found
Since the domains are bogus how do i turn off these NDR's for domains that are not on our server?
This is an Exchange 2010 and we have around 25 domains on the box.
For now i turned off NDRs all together, i realize this is not permited by RFC however it is killing the performance on the box.
Please help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Technical Manager
Top Expert 2010
Commented:
Go to Hub Transport\Remote Domains\Default Properties\>>Uncheck Allow delivery reports

Restart Microsoft Exchange Transport service.

Author

Commented:
that seems to kill all NDRs.
If i send an email to jimbob@abcd.com and we are hosting abcd.com on the server but there is no jimbob account it does not send an ndr.  How can i kill it for just domains that are not hosted on the box?