Exchange 2003 server SMTP not working?

RBraat
RBraat used Ask the Experts™
on
I'm running Exchnage 2003 SP2 on Windows 2003 R2 for a long time, without problems. Now, just after a reboot, mail stops working. Everything look s fine at first, but it seems like the SMTP process does not work anymore (also tried reboot and killed inetinfo.exe.
When I telnet tot the server over port 25, there is no anwer (should be). When I look in Exchange system manager, there are no queus.
I run popcon (http://www.servolutions.com/popcon.htm) because my provider is blocking port 25. Popcon also cannot deliver mail to exchange and stops. On the moment I kill inetinfo.exe, popcon tells me the connection is lost. It looks like a connection is made, but then is stuck.
When I look in system manager at the current SMTP connections, the connection is shown. but nothing works.
In event viewer I see an error from MSExchangeSA, category "General", ID 1031: One of the System Attendand's task is blocked. Function: CMonitoringTask::Work
Any Idea's?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Technical Manager
Top Expert 2010
Commented:
Please refer this article: http://support.microsoft.com/?kbid=906154
Praveen BalanSolution Architect

Commented:
just see if you did any changes to the server, like patching etc.

Try disabling all Antivirus product and other thirdparty if any and take a server reboot.

If the issue did not solve, please enable diagnostic logging for MSExchangeSA for more detailed events, also see any errors logged for SMTP services in event logs.

Author

Commented:
This was the propblem and fix.

AutoFix in the article did not work, manual fix an reboot did the trick.

Thnx

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial