ASMX Web service created with VS 2008 has Parse Error when published with IIS 6

bobcann
bobcann used Ask the Experts™
on
I have an ASMX webservice I created using Visual Studio 2008.
When compiled and published to a box with server 2008 (64 Bit OS) that has IIS 7 it works.
However when published to a Server 2003 (32 Bit OS) with .NET Framework 3.5 sp1 installed that has IIS 6.

The following error comes up when trying to open the published web service’s Service.asmx file in a web browse. Does anyone know a fix for this? Thank you for any help you give.:

Server Error in '/' Application.
________________________________________
Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not create type 'Service'.

Source Error:

Line 1:  <%@ WebService Language="vb" CodeBehind="~/App_Code/Service.vb" Class="Service" %>

Source File: /Geocode_Test/Service.asmx    Line: 1
________________________________________
Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053

compiled VS 2008 ASMX Webservice
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
You might need to change the Platform in the Configuration Manager of Visual Studio to build for the x86 platform explicitly. This also means you would need two sets of DLLs, one for each server, built for the right platform.

Author

Commented:
Thank you

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial