Project 2007 can't save files

SterlingMcClung
SterlingMcClung used Ask the Experts™
on
I am struggling with a computer that does not want to save a set or project files.  The files are organized into a master file with various other project files linked to the master.  Sometimes when the user opens the master file or the individual files, he is unable to save them.  He gets the following message:

Project Error
These files are stored on the a SBS2008 server, and when the files are stored locally he does not have problems.  We can save or store other files in this folder just fine, it seems to be just Project that is having troubles.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2013
Commented:
I am afraid I am not a lot of help, but it is an interesting question and where you have had no replies I though I would pitch in.

When saving, if you choose save as and choose another name in the same location, does the problem still exist?
It is possible it 'thinks' the file is open by another process and thus makes it read only. This would be a first test.
If that makes a difference, and it is not open by another user, I would first try disabling antivirus scanning of that directory by both the PC and server. That may require disabling A/V just as a test.

There are also some known issues with network performance with SBS 2008 or actually any 2008 version including Win7. These can result in delays or failed saves, though I haven't seen your issue. I am wondering though where you have linked files it could be related. Please see the following from a previous post of mine regarding these issues.

There are some known issues with newer advanced NIC properties such as "Task Offloading", and “Receive-Side Scaling” which drastically affect performance and stability of file share access if enabled and especially if you are running older drivers. These should be disabled on the PC and server. Though the recommendation is to do so from a command line, I have found I also had to do so from the advanced configuration properties of the NIC to take effect. These changes require a reboot to be effective.

To disable Receive-Side Scaling, at a command prompt, with elevated privileges, run the the following command:
netsh int tcp set global rss=disabled

To disable Task Offload, at a command prompt, with elevated privileges, run the the following command:
netsh int ip set global taskoffload=disabled

To disable Add-On Congestion Control Provider, at a command prompt, with elevated privileges, run the the following command:
netsh int tcp set global congestion=none

For more information Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://go.microsoft.com/fwlink/?LinkId=189029

Related blog articles:
http://blogs.technet.com/b/networking/archive/2008/11/14/the-effect-of-tcp-chimney-offload-on-viewing-network-traffic.aspx
http://blogs.dirteam.com/blogs/sanderberkouwer/archive/2008/05/15/backward-compatible-networking-with-server-core.aspx
http://support.microsoft.com/kb/951037
http://msmvps.com/blogs/thenakedmvp/archive/2010/02/23/rss-tcp-offloading-strikes-again-microsoft-should-kill-this-feature-for-the-masses.aspx

Author

Commented:
When the message happens, if we try saving under a new name in the same location, we get the same message.  I believe that we also tried saving these files to his "Desktop", which is redirected to a share on the server, with the same results.  This has been a long running issue and we have changed AV products with the error happening before and after.  I believe that with the original AV product, I did try disabling the AV on the desktop and server as a test, but it still did not work.

I have not specifically enabled these NIC settings on either the desktop or the server, but I will check to ensure they are not enabled.  The network was one of my thoughts as well, and one of the last things I have done is replace all the network cable, including vertical, from the desktop to the switch, because the switch and computer would only auto negotiate a 100 Mbps connection instead of 1 Gbps.  With the new cable, everything is auto-negotiating to 1 Gbps, but the problem persists.  I will try the settings and if that doesn't work, I think a new NIC will happen this week as well.

I will post again after I have had a chance to read through the article you posted.
Top Expert 2013

Commented:
It is common for A/V to cause a file to show as "open by another user" and thus read only.

The NIC settings referenced are enabled by default, and generally require disabling.

In my past life I was a cabling troubleshooter. 90% of network related issues are cabling related. Unlike a phone line that if you have a connection it works, poorly terminated cables, kinked or stretched cables, and EMI cause reduced performance that can really only be tested with a proper network certification meter (>$8000). If in doubt you should have the cabling tested by a specialist.

Also make sure PC's, servers, and switches use the same speed and duplex settings. Auto-negotiate is usually best, and only option to use if they are unmanaged switches.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial