Terminal Server Sessions Ending Abnormally

Generator
Generator used Ask the Experts™
on
We have users connecting to a Win 2003 R2 T.S via RDP. They are now complaining that if they walk away from their computer for about 10-15 minutes that their terminal server session has logged them out completely including any programs they were working on. They are losing any data that they had been working on prior to the disconnections. This is happening in both Windows XP and Win 7 workstations. We have made sure that the screen saver login feature is not active and that their power settings are set to never shut off, If there is a policy in place on the server - please tell where I can find it.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sandesh DubeyTechnical Lead
Top Expert 2011

Commented:
Check the terminal Service configuration setting on the server as mentioned below
Click on Start | Control Panel | Administrative tools
Click on Terminal Services Configuration
Click on the Connections folder, then, on the ride side, right click RDP-Tcp and select Properties
On the Sessions tab and see the setting which is causing the issue.

Author

Commented:
Here is a scrren shot of the window you mentioned.
Sessions.png
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
The sessions are ending without any error messages. They get the Remote Desktp Connection window and must log into the T.S. and restart all their programs they had been previoulsy working on.
Sandesh DubeyTechnical Lead
Top Expert 2011

Commented:
Check if any group policy is deployed on the TS Server local or through GPMC.

These Group Policy settings are located in the following locations:

Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Session Time Limits

User Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Session Time Limits

Note:These Group Policy settings can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC). Note that these Group Policy settings will take precedence over the settings configured in Terminal Services Configuration. If both the Computer Configuration and the User Configuration policy settings are configured, the Computer Configuration policy settings take precedence.

Author

Commented:
Sandeshdubey - I need to access "Set time limit for active but idle Terminal Services sessions" but I'm having problems finding that group policy. Could you please provide some additional detail on where I can find:
Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Session Time Limits
User Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Session Time Limits
I have looked in the DC but can't seem to find that path - thanks

Author

Commented:
OK - run - gpedit.msc
None of the policies have been configured - if I configure the Computer Configuration Policy - time limits to say - 8 hours, would this solve the problem of the disconnects if indeed there is another policy in place that has a lesser time out limit? Would I do this on the DC or TS or both? We have 4 Terminal Servers  and one DC - all the users are experiencing this issue.
Sandesh DubeyTechnical Lead
Top Expert 2011

Commented:
If you have set it to 8 hrs then session will be disconnected after 8 hrs.If you have not deployed any other GPO for the same then it should not disconnect.

You can configure the same both on TS as well on DC.

Author

Commented:
We also recently changed out three Sonicwall TZ-170 for TZ-210. There seems to be more security setup on the new firewall units as defaults. Normally when an RDP connection is established through the VPN it is done so via TCP and after a time (15min) the connecton switches to UDP due to its lower overhead. I have changed the 15min TCP connection to 480min (8 hours) to see if this makes any difference. If this is not the answer I will try the GPO setting. Thanks..
The problem is solved. The Sonicwall TZ-210  - Firewall - Access Rules - Matrix - LAN to VPN - LAN Subnets - edit - Advanced - TCP Connection Inactivity (minutes) - change this value from 15 minutes to 480 minutes (8 Hours). No more timeouts.
Thanks for participating.

Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial