SharePoint 2010 Cross-site List error

schal1r
schal1r used Ask the Experts™
on
To display a list on a child site we follow these steps:
add the list on the parent site
open the site in SharePoint Designer and edit the page the webpart is on
export the webpart to file
on the child site, import the webpart to the page.

At this point the webpart displays properly.  However on the same page we display a document library.  When a user clicks a folder of the document library and the page reposts, we receive the following error:
"The object specified does not belong to a list."

We recreated this issue using a variety of different types of lists, but the list tye we are trying to get to work is a custom list type.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
It seems that this issue is/was being discussed in another forum.  It appears to be an issue with the wa the webpart gets exported/imported.  I was importing the webpart using the browser which appearenty causes the error.  Importing the webpart using SharePoint Designer seems to correct the problem and allows for the imported webpart to be exported and imported using the browser after the initial import.

Here was a link to the other forum is anyone wanted to follow-up:
http://social.technet.microsoft.com/Forums/en-US/sharepoint2010customization/thread/96323403-472f-47d9-a72c-7c6fb36a2000/

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial