Windows XP WiFi says "Automatic" but I'm not connected.

drose10
drose10 used Ask the Experts™
on
Hello:

A user recently clicked the network diagnostic feature on his Windows XP laptop when hen could not remember the SSID password on a home Wi-Fi router (the usual NetGear type).  The Wi-Fi will now correctly recognize the network ID from the Tasktray, but will not actually connect to the router after entering the Wi-Fi password.  The wireless networks panel just reads "Automatic" instead of "Connected."  Several other computers in the house connect wirelessly, and the laptop in question connects to the Internet normally by means of a wired connection.

I have tried disabling the Windows Firewall, to no avail.  I have also verified that the Wireless Zero Configuration services is running.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
I have had a couple of situations where the signal was barely good enough to read the SSID but not good enough to actually transfer data.  The main way to check for this is to take the computer into the room where the router is and try it within about 10 feet of the router.  If it works then, it's a signal strength problem in it's normal location.

Author

Commented:
I have already brought the the laptop very close to the router, but no luck.
Commented:
Try opening command prompt and enter: netsh winsock reset

Then reboot and try connecting. I have this happen all the time and this usually works for me

OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

I would remove the connection - disaccosiate the two.   Release IP via ipconfig /release all  and then reconnect.

Most Valuable Expert 2011
Top Expert 2011
Commented:
Disconnect from the router, and verify it is the right key using this tool....

http://www.nirsoft.net/utils/wireless_key.html

Do that from a working PC.... Sounds like it's just not the right passkey....
Commented:
I would delete the Wireless profile from the advanced menu. If you right click the wireless fromthe task bar then properties from there you should see the wireless profiles that the laptop as connected to in the past select and delete the profile in question and then click ok and start the connection process again. sometimes if you have previously connected to a particular network then update the drivers or windows then passkey can become corrupt even though you have typed it in because it has not successfully connected the profile will not be updated.
Also make sure that some third party software is trying to control the profile like Lenovo for example although windows controls the wireless profile the "ThinkPad access connection" program made by Lenovo will overide the windows settings
Darude1234IT Employee (Developer & Helpdesk)

Commented:
I've seen this problem a couple of times. Most of the times the problem is solved after one of the following actions:
- Remove the network from the list of preferred networks and re-add the network
- Check if another program is managing your network connections and connect to the network using that program or disable that program and connect to the network using the windows wireless connection dialog.
- Reinstall the wireless network driver.
- Reboot the router

Author

Commented:
I have removed all wireless networks several times and re-entered the passkey from scatch, but I am still unable to connect.  I am absolutely sure I have the right passkey, because I was able to connect on several other computers in the house.  I rebooted the router several times and checked that the firmware is up-to-date.  I was not able to uninstall the wireless driver through Device Manager, so I will have to look for an uninstaller through Add/Remove Programs in Control Panel.  The driver is very old, and I was unable to find an updated one on Intel's website.

I thought since Windows was managing the network list, there are no other programs managing the wireless connection.  The laptop is a ThinkPad, however, so jaramart is right to suggest that I check for third-party wireless managers such as the "ThinkPad access connection."

Thank you for your suggestions.  I will apply these remedies tomorrow and post my results.
Commented:
What thinkpad is it? I had this very thing with the thinkpad r60 which is the same for the r51 and r61. This particular model can have up to three different ways to control the wireless profiles. 1. Windows itself. 2. Lenovo access manager. 3. The intel drivers for the proSet wireless card also have there own software to manage profiles. And just a final thought have you installed lenovo toolbox? As this also has wireless profile manager as well.
Imal UpalakshithaIT System Administrator

Commented:
did you try changing wireless channel on both side ?

Commented:
the wireless channels are by defualt normally set auto. so there should no reason to this unless someone has been tinkering
Darude1234IT Employee (Developer & Helpdesk)

Commented:
You can check which wireless channels are in use in your area with inSSIDer and change it in your router according to the results of the program.
Imal UpalakshithaIT System Administrator
Commented:
If there is no other wireless networks in around & when channel mode is auto, the selected channel is 1 by access point or router.some times, some of wireless network cards can not connect to channel 1 range. As I have seen channel 5 & 6 is best for most of Wl network cards

Author

Commented:
I was never able to connect.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial