Exchange 2003 to 2010 mailbox migration going very slow

lanlinehelp
lanlinehelp used Ask the Experts™
on
In the process of migrating from a Exchange 2003 to Exchange 2010 running on Windows 2008 Enterprise R2.

The mailbox migration is taking forever. 1 gig mailbox taking 12 hours. Something is not right.

Any body experience this before?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
- Update NIC Drivers.

- Disbale TCP/IP Offloading on the NIC.
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
One more thing to check...Does you have any mail scanner application on Exchange 2003. If yes, then disbale during the migration.

Author

Commented:
Ok. I trying that now.

I also tried this below. It is at least doing more then 2 a time now.

The first test mailbox move was a GIG and went in 15 minutes.  

Wondering if this is some Microsoft limit on something stopping me.

Steps:
  1. Goto MSExchangeMailboxReplication.exe.config
  2. Make a backup copy of the file in alternate location before you customize it.
  3. Edit the MSExchangeMailboxReplication.exe.config using Notepad.
  4. Edit MaxActiveMovesPerSourceMDB, This property indicates the number of mailboxes that can be moved on the source mailbox database at one time. The default value is 5 concurrent moves. Change it as per your Requirement.
 5. Edit MaxActiveMovesPerTargetMDB, This property indicates the number of mailbox moves that can be moved on the target mailbox database at one time. The default value is 5 concurrent moves.Change it as per your Requirement.
 6. Edit MaxTotalMovesPerMRS, This property indicates the number of mailboxes that can be moved by a single instance of MRS. The default value is 100 concurrent moves. Change it as per your Requirement.
 7. Edit MaxActiveMovesPerTargetServer, This property indicates the total number of moves that can occur on the target server at a given time. The default value is 5 concurrent moves.Change it as per your Requirement.
 8. Edit MaxActiveMovesPerSourceServer,This property indicates the total number of moves that can occur on the source server at a given time. The default value is 5 concurrent moves.Change it as per your Requirement.
 9. Save and close the file.
 10. Restart the Microsoft Exchange Mailbox Replication service
 11. Try to Create new Move Requests.


Also tried this based on this article I saw in another forum
http://support.microsoft.com/default.aspx?scid=kb;EN-US;982860

Workaround for Windows 7 and for Windows Server 2008 R2
To work around this issue, disable the Server Message Block (SMB) signing through registry keys. To do this, follow these steps:
Click StartCollapse this imageExpand this image, type regedit in the Search programs and files box, and then press ENTER.
On a server, locate and then click the following registry entry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters
On a client computer, locate and then click the following registry entry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters


Under the registry entry, disable these two registry keys:
Right-click Enablesecuritysignature, and then click Modify. Type 0 in the Value data box and then click OK.
Right-click Requiresecuritysignature, and then click Modify. Type 0 in the Value data box and then click OK.
Back to the top

Author

Commented:
Also just tried this from another forum on my 2008 server.

netsh interface tcp show global      (check settings)

 

netsh interface tcp set global autotuninglevel=disabled

netsh int tcp set global chimney=disabled

netsh int tcp set global rss=disabled

 

reboot server and then check settings again

 

should show disabled


Author

Commented:
Still no luck. Help!
Basically Microsoft was no help. Migration took a very long time, we ended up setting up dual environment with Exchange 2003 and 2010 clients on both databases worked until we move the rest of the mailboxes over a few evenings.

Author

Commented:
The key to dual environment is having OWA, Outlook anywhere and Activesync setup for the dual environment. I'll see if I can dig up the articles and post them.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial