Setup NFS on Windows server 2003

RBraat
RBraat used Ask the Experts™
on
I have a mediaplayer ACryan PlayOnHD, wich is Linux based. It has the ability to connect to a NFS share.
I'm running WIndows Server 2003 R2 and installed NFS on it. I was able to share a directory with NFS. On the mediaplayer I can browse to the server and connect to the NFS share. But then, no file is visible.
I don't know much about NFS, probably forgot something.
Any suggestions?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2017

Commented:
How did you mount the NFS share?
What are the security settings?
Does everyone have read access?

Author

Commented:
Like I told, I don't know much about NFS.

Wat I did on the media player is select NFS in the browser. Here I can create a new NFS connection. I have to specify the IP address and de NFS share name. I did this and the mediaplayer connects. To test if it was succesfull, I also tried a wrong IP and NFS name. When I do so, it tells me it cannot connect. So, after entering the correcty info, it tells me nothing (no error), so I assume this is the mount process and it succeeded.

On my Windows 2003 server I go to MSFT services for NFS, rightclick on "Microsoft Services to NFS" and I enter my IP of my server in "User Name Mapping Server". AD lookup is not selected.

In the properties dialog of "User Name Mapping" in the tab "UNIX User Source", "Use Password and Groupe files" is selected. I wouldn't know which filesnames to enter on "Password file path and name" / "Groupe file path and name". On the tab "Simple mapping", "use simple maps" is not selected.

In the properties dialog of "Server for NFS", all is default.

In th eproperties dialog of "Client for NFS", all is default. The tab "File permissions" shows:
Owner: RWX
Groupe: RX
Others: RX

Furthermore, in the User Name Mapping | User Map, I created a new map. On the left I see my windows domain and I select administrator (can narrow down permissions afterwards). When I "list unix users", is showes: Unix User: <unmapped>, UID: -2. Clicked ADD.
It seems there is now a mapping between my administrator account and UNIX user <unmapped> in the PCNFS Unix domain. UID=-2, Primary=*, type=advanced.

I repeated this when creating a map in User Name Mapping | Groupe Map.

As far as I can see this is everything I can set. Any help appreciated.

Regards

Author

Commented:
addition:
On windows 2003 I shared a folder with NFS sharing. Permission settings:
- allow anonymouw access selected
Anonymous UID: -2
Anonymous GID: -2
Permissions: ALL MACHINES: Read-Only, ANSI encoding, Root Access Allowed
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
Anyone?
Commented:
did you use same uid and gid on both machines?
the official procedure use a copy of /etc/passwd and /etc/group to extract uid and guid to have identical access on both sides.
check these links :
http://ubuntuforums.org/showthread.php?t=310168
http://www.rtfm-ed.co.uk/2006/04/20/beta-esx-30-and-virtualcenter-20-setting-up-nfs-on-windows/

Author

Commented:
Like I told above:

"In the properties dialog of "User Name Mapping" in the tab "UNIX User Source", "Use Password and Groupe files" is selected. I wouldn't know which filesnames to enter on "Password file path and name" / "Groupe file path and name". On the tab "Simple mapping", "use simple maps" is not selected."

Maybe this is the problem?
When I telnet to the mediaplayer I can login with ROOT (without password) and I see the files passwd en group (command ls) in /etc. But how do I get these files out of the filesystem so I can specify them in NFS for Windows Server?
I see the files in a telnet session, but when I browse to the mediaplayer (as a NAS), I only see the music and movie content.

Told you I am no good in NFS, almost nothing in Linux.

Commented:
you have several options to do that :
/etc/passwd and /etc/group are textfiles

Use free windows program winscp to connect and copy over ssh http://winscp.net/eng/index.php
or just do a copy paste from your telnet client screen of the two files into basic textfiles on your windows server.



Author

Commented:
It's working!

Didn't succeed with winspc, could not setup a session.
Now I started VI editor and copy/pasted the content of passwd into a new text file. Specified this textfile in NFS for Windows as password file. Made a new mapping (could now select "root" als UNIX user) and that was it. Group file was empty, did not use it.

Many thanks!

Author

Commented:
Thnx!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial