FileZilla on WHS - ftp works but no folders

AD_Tech
AD_Tech used Ask the Experts™
on
I setup FileZilla on Windows Home Server and tested my connection on ftptest.net successfully but I do not see the folders and cannot successfully copy files.
It has to be a FileZilla setup issue but I cannot figure it out.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
Did you create users in FileZilla server and grant them read or write access to shares / folders on your WHS machine?

Author

Commented:
yes I did. I created 2 groups also.

Author

Commented:
I just shared a folder in Users on Filezilla to my user file. Now I see a folder when I ftp but the folder is the name of my user and the folder is in the FTPusers folder on c:\.
The instructions at: http://computingondemand.com/filezilla-ftp-server-on-whs say to create FTPusers on the c, and share the folders through Filezilla's interface (through groups, not users) that are shared on whs.
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Topic Advisor
Most Valuable Expert 2016
Commented:
I just manually create a folder like c:\ftp_home and create a subfolder for each user that I want to give access. You can create multiple shared folders like c:\data - c:\programs etc. and create aliases to c:\ftp_home\data and c:\ftp_home\programs, set c:\ftp_home as Home directory for the user and you're done. If you can't get it to work, let us know how you would plan your ftp access (for one user) so we can create you a sample.

Author

Commented:
Yes, I was able to recreate what you did above successfully. Thank you.

What isn't working is when I use groups and try to connect to my WHS "windows home server".

The way you showed me (users) is working and I can use it for now but I really wanted to set it up like the link about.
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016
Commented:
I've tested when using groups. I setup a group ftpusers with homedirectory d:\ftp_home and a d:\download folder with a /download alias

The autocreate checkmark causes creation of d:\ftp_home<username>

I created a test user, put it in the group ftpusers and gave the users no rights or shared folders.

Logon as the test user shows the /download directory and creating a 'test' folder results in a folder d:\ftp_home<username>\test

This works OK for me.

Where exactly do you get errors when trying to give rights to the WHS shares?

Author

Commented:
I actually connected to the FTPusers folder but could not see any folders (just an empty /folder.
I could not ftp anything to this empty / folder

It has to be the way I am configuring the FileZilla software.

I will test what you did above and get back to you.
Thank you.
This sounds like an issue with your Passive FTP settings. The server is connecting on port 21 for the initial connection, but with passive mode, it switches to a separate port when you list directory contents, copy files, change folders (data transfer).



To fix this issue:
Check/Limit your Passive FTP Port range here:
http://wiki.filezilla-project.org/Network_Configuration#Passive_mode_2
Make sure those ports are open in the server firewall (hardware firewall/software Windows Firewall, etc.)
Make sure this port range is forwarding to the WHS server in your network.
Make sure those ports are open in your client outbound firewall ruleset.
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
You may have to stop/start the ftp server to be sure all settings are applied. I added some screenshots of the working configuration I made. Note with 2nd image: I've set the same security for both the Home folder and the download folder.
gftp1.png
gftp2.png
ftp1.png
ftp2.png

Author

Commented:
gerwinjansen:
That worked. Thank you.

pete-mcpetey:
I will research this. Thank you.

Author

Commented:
still can't connect outside of my network. must be a router issue.
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
> must be a router issue
Maybe, what network components (switches/routers/modems etc) are there between your FTP client and the (WHS) server you are trying to FTP to?

Author

Commented:
Belkin Router  N450         F9K1003 v1 (01A)

Optonline Cablevision ISP     Modem - arris tm802g
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
Hi, looked at your modem, cannot find any options that mention a built-in firewall.

Your router however has a built-in firewall that needs to be configured in case you want to allow access from outside to your WHS server using FTP. I'm assuming that you didn't do this already.

What you have to do is to forward port 21 for FTP to your WHS server using this procedure. I'm assuming that your WHS server is connected wired to your router.

The procedure above is for setting up access from outside your network, you should be able to test FTP funtionality from inside using a wired or WiFi connection.

Note that you should set a difficult password for the user your'e granting FTP acces from the outside. This to prevent unauthorized access from the outside. You should monitor your FTP server logs and WHS logs as well.

Author

Commented:
Yes, I have port 21 open to my WHS. I will test with the open port check tool tonight.
Thank you.
Try resetting your router. Port 21 will work but passive FTP switches to an alternate, random port which needs to be open in your outbound firewall and router config.

Author

Commented:
FileZilla on WHS is now working. I reset the router and then ran the WHS connection configuration again. This worked.

Thank you all
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016
Commented:
Great you've got it working :) Thanks for your feedback!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial