We help IT Professionals succeed at work.

urgent ... please help  ubuntu is hosed..

tmonteit
tmonteit used Ask the Experts™
on
help... ubuntu won't recognize my nic card or connect to the internet.  its supposed to be a wifi card but it won't recognize wifi either.  

all I have is ' edit connections' and that is no help.

I need to make this hardware work.  what can I do?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
I opened terminal and ran nm-tool

says:  etho: unavailable
           wifi: unavailable

There is a wifi router right next to me and and I'm also wired into it.  WTF??!!

How can I force this to work?

Author

Commented:
sweeffa2...  The first thing It says is to run:  sudo apt-get  

That requires an internet connection and I that's not working.
Commented:
You obviously have an internet connection to send this on a different machine.  Download the package from NDISWrapper download.

When you have downloaded it copy to a usb stick or cd and copy it to your machine.

Then install it How to install
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
If you have your Ubuntu CD, run it as a 'Linux Live' (no install) and see if it connects thru your NIC.

Author

Commented:
sweetfa2,  Yes,  I am on a different computer to post this message.  Sitting next to me is the problem ubutnu machine.  Just downloaded:  ndiswrapper-common_1.50-1ubuntu1_all.deb and moved it over onto a thumb drive.   How do I install the package onto the ubuntu machine?   beginner here step-by-step please.
       
Dave, If I run UbuntuCD as 'Linux Live' it does not detect my my wireless NIC.

Thanks, I hope I can work through it....

Commented:
Follow the link on how to install in my previous post.

Author

Commented:
Ok,  I still cannot get a wifi signal.  On the wifi menu at the top of the screen it still says under wireless networks:  device not ready (firmware missing)

Here's what I did:    I installed packages:
For 11.04 Natty Narwhal:
     http://packages.ubuntu.com/natty/misc/ndiswrapper-common
     http://packages.ubuntu.com/natty/misc/ndiswrapper-utils-1.9
     http://packages.ubuntu.com/natty/net/ndisgtk
       
Then I did
  echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf

But still no joy... :(  Am I on the right path?  What next?
Commented:
3.2.1. PCI Wireless Adapter

    Open a Terminal (Applications | Accessories | Terminal), type lspci and press the return/enter key.

    Look through the output of the lspci command for an entry for your wireless card.

    Once you have identified your card, note down the contents of the first column, which should look like 0000:00:0c.0.

    Now, type lspci -n into the Terminal and press return.

    Find the PCI ID for your device. Your device will be referred to in the output of the command by the identifier which you just made a note of, e.g. 0000:00:0c.0. The PCI (chipset) ID will be in the third column of the output and will be in the form 104c:8400.




Did you do this?
Commented:
After that install the windows drivers as per the instructions in the original link.
If your system is not a laptop. Then my suggestion is that install a NIC card and update your ubuntu by configuring the NIC. Once updated it will be able to detect the wireless device.

Once your wireless device is ready, the remove the NIC Card.

Thanks.

Kishor Das

Author

Commented:
Ok... Here is the output to my lspci commands.
lspci.txt

Author

Commented:
Ok...  I think we're talking about this number in column 3 of lspci -n:   "14e4:4320"

Which is in section 3.2.1. PCI Wireless Adapter of sweetfa2's link.  

Then I went to Admin > Wireless network Drivers.  And it wants an inf file.

I'm struggling with the next part because it wants a  windows 'inf' file and I don't have any windows CDs or windows on that machine.  Which is why I've gone to ubuntu.

Can I download this inf somewhere?