How can I make all windows/shortcuts open maximized by default in windows 7?

exchangbob
exchangbob used Ask the Experts™
on
How can I make all windows & shortcuts open maximized by default in windows 7?
Already tried a few answers in EE Knowledge Base, no help?  This seems to be an insurmountable problem?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kent DyerIT Security Analyst Senior

Commented:
I think you will need to tweak/update your shortcuts using the following vbs:

set WshShell = WScript.CreateObject("WScript.Shell")
strDesktop = WshShell.SpecialFolders("Desktop")
set oShellLink = WshShell.CreateShortcut(strDesktop & "\Shortcut Script.lnk")
oShellLink.TargetPath = "notepad.exe"
oShellLink.WindowStyle = 0
' -- 1 is normal window
' -- 2 is normal window
' -- 3 is maximized
'oShellLink.Hotkey = "CTRL+SHIFT+F"
oShellLink.IconLocation = "notepad.exe, 0"
oShellLink.Description = "Shortcut Script"
oShellLink.WorkingDirectory = strDesktop
oShellLink.Save 

Open in new window


HTH,

Kent

Author

Commented:
This sounds like exactly what I need to fix this.  Could you please elaborate/be more  specific on(how to) with  the vbs. ?and tweeking/updating  my shortcuts?

Author

Commented:
This sounds like exactly what I need to fix this.  Could you please elaborate/be more  specific on(how to) with  the vbs. ?and tweeking/updating  my shortcuts?
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Author

Commented:
there doesn't appear to be a fix for this problem since I have no idea how to complete the instructions in 08/07/11 07:14 PM, ID: 36326426? and have received no other replies.?
Well it maybe just a simple thing, I have windows 7 and opened my documents shortcut on my desktop, the folder was not at full screen so clicked on the square and made it full screen, closed it then opened the shortcut again to my documents and windows remembered my new setting and the folder was at full screen. tried the other shortcuts  local network my computer same thing
all at full screen.

Author

Commented:
That's what I expected to happen with my windows 7.  I have tried this method several times, but was unable to get the same result as you.
Most Valuable Expert 2011
Top Expert 2011

Commented:
Normally, if you drag the window to the size you want, and hit CTRL+X to close, it is a FORCED remember.....

Libraries from what I understand follow their own rules though.

There's allot of discussions on this on the web.

Known about this reg mod, but never tried it....

http://brianary.blogspot.com/2009/07/best-registry-hack-ever-maximizeapps.html
Most Valuable Expert 2011
Top Expert 2011
Commented:
And I think this thread explains the situation, with a discussion from an MS developer.....

Can we get a straight answer - Windows does not remember window size and position - Bug or by design? Workaround?
http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/5b524d53-df97-405d-835f-f081d106a19b/

There's information in there regarding deleting keys, hotfix etc... Never had to go through it though, as I have never experienced the problem personally....

Author

Commented:
Thanks.  I will look into this and let you all know.  I would love to finally have this problem solved.  It's been like a bad dream.  By the way, I tried CTRL+X to close , but it didn't help.

Author

Commented:
I FOUND THIS POST ON THE SITE:
http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/5b524d53-df97-405d-835f-f081d106a19b/
THAT JOHNB6767 GAVE ME. UNTIL MICROSOFT COMES UP WITH A FIX FOR THIS BUG, IT WILL BE OKAY WITH ME. IT MAXIMIZES TO WITHIN A 32ND OF AN INCH? BUT WHO' COUNTING?
gee, maybe microsoft will provide a permanent fix to this problem in windows 8,9 or 10?????????




Wednesday, November 04, 2009 8:07 AM
MJS1A  I think that I figured it out. When resizing the window DO NOT let the border touch the taskbar. Then close it with the X and open it again. Works for IE and Win Explorer.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial