Access 2010 Crashing

jrogersok
jrogersok used Ask the Experts™
on
I have a new Access 2010 database I created today that has started crashing inconsistently.  I have a form that opens on start up and all of sudden it stopped working when loading.   I was able to open the database using the Shift-double-click technique to get to the main database window.  I can open the forms but some other forms now crash.  I've tried compacting and repairing and it crashes too.

I'll attach the file with the startup form displaying.  This is a test database so you can enter 99999 as the Stakeholder ID when the form displays which will then display several buttons to open various forms.  A pretty simple database with a small amount of macros and vba code.  Now I can't access any of the VBA code either; it comes up with the message "File Not Found" or crashes.

I have been creating databases with Access for 20 years and needless to say, this is very FRUSTRATING!   Will it ever be possible for Microsoft to come out with a program without a zillion bugs?????

I am running Office 2010, SP1 on a windows 7 machine.

Thanks!   Crashing-DB.accdb Crashing-DB.accdb
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
have you tried to see if the file is corrupted or can be opened in other system/access version?

have you tried:
 http://office.microsoft.com/en-us/access-help/compact-and-repair-an-access-file-HP005187449.aspx

or this:

http://support.microsoft.com/kb/283849

or any of the other repair options?

if that doesn't work then you will need to disable DEP:

Your system might think the file is malicious and DEP is preventing it from working just in case.


Disable Data execution prevention for Access by:
computer>right click>properties>advances system settings>advanced tab>performance button>data Execution Prevention tab>Browse to access's .exe file>ok to close all dialogs
It is working in Access 2010. I've found only one possible problem:
You have not described variable StakeholderID and have no Option explicit.
Infotrakker Software
Most Valuable Expert 2012
Top Expert 2014
Commented:
It also works on my 2010 machine, and the code compiles on my machine. I am running the same configuration as you are.

This would lead me assume either you've got a corrupt copy of Office/Access, or a corrupt/bad Windows installation. I'd try a Repair on your Office installation first to see if that resolves it.

Author

Commented:
Thanks!  It was a corrupted system.  I was able to run it ok on my son's Mac with a virtual Windows box.

Thanks for everyone's suggestions

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial