Quota over NFS mount in CentOS 6

cloudbase
cloudbase used Ask the Experts™
on
Hi,

I've exported storage from my NAS storage to one of my CentOS servers to use it as NFS mount point.

I edited /etc/fstab accordingly:
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
xxx.xxx.xxx.xxx:/vol/vol6/sharednfs    /mnt/sharednfs        nfs     rw,retry=5,rsize=8192,wsize=8192              0 0

now I need to enable quota on /mnt/sharednfs.

Can anyone assist me on how to do it?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
In /etc/fstab file edit the line so as to read,

xxx.xxx.xxx.xxx:/vol/vol6/sharednfs    /mnt/sharednfs        nfs     rw,usrquota,grpquota,retry=5,rsize=8192,wsize=8192              0 0

Add the grpquota entry only if you need group quotas enabled else you can leave it

Remount the share
mount -o remount /mnt/sharednfs
In /mnt/sharednfs,
touch aquota.user
chmod 600 aquota.user
quotacheck -vagum #command to run for initializing

Now edit quotas for users
edquota -u myuser
You can enforce quotas for inode numbers and blocks

good luck!

Author

Commented:
Hi,

thanks for your reply.
I've done as you said, however, when I'm trying to remount it with usrquota, I'm getting:

Unsupported nfs mount option: usrquota

What is wrong here?
Can you post the last few lines of /var/log/messages and dmesg

tail -30 /var/log/messages
dmesg | tail -20

Author

Commented:
[root@host-6e-174 ~]# tail -n30 /var/log/messages
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: Core ver 2.10
Aug  8 14:21:36 host-6e-174 kernel: NET: Registered protocol family 31
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: HCI device and connection manager initialized
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: HCI socket layer initialized
Aug  8 14:21:36 host-6e-174 hcid[11105]: Register path:/org/bluez fallback:1
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: L2CAP ver 2.8
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: L2CAP socket layer initialized
Aug  8 14:21:36 host-6e-174 sdpd[11111]: Bluetooth SDP daemon
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: RFCOMM socket layer initialized
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: RFCOMM TTY layer initialized
Aug  8 14:21:36 host-6e-174 kernel: Bluetooth: RFCOMM ver 1.8
Aug  8 14:21:37 host-6e-174 pcscd: pcscdaemon.c:507:main() pcsc-lite 1.4.4 daemon ready.
Aug  8 14:21:37 host-6e-174 pcscd: hotplug_libusb.c:402:HPEstablishUSBNotifications() Driver ifd-egate.bundle does not support IFD_GENERATE_HOTPLUG. Using active polling instead.
Aug  8 14:21:37 host-6e-174 pcscd: hotplug_libusb.c:411:HPEstablishUSBNotifications() Polling forced every 1 second(s)
Aug  8 14:21:39 host-6e-174 kernel: Bluetooth: HIDP (Human Interface Emulation) ver 1.1
Aug  8 14:21:39 host-6e-174 hidd[12334]: Bluetooth HID daemon
Aug  8 14:21:41 host-6e-174 automount[12389]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Aug  8 14:21:42 host-6e-174 gpm[12491]: *** info [startup.c(95)]:
Aug  8 14:21:42 host-6e-174 gpm[12491]: Started gpm successfully. Entered daemon mode.
Aug  8 14:21:46 host-6e-174 : INF [SYSTEM 56:12560:b5bffb90 pleskd]: [HSStateMonitor::reportStates] No services have changed state: nothing to report
Aug  8 14:21:47 host-6e-174 rhnsd[16820]: Red Hat Network Services Daemon starting up, check in interval 240 minutes.
Aug  8 14:21:48 host-6e-174 smartd[16858]: smartd version 5.38 [x86_64-redhat-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Aug  8 14:21:48 host-6e-174 smartd[16858]: Home page is http://smartmontools.sourceforge.net/ 
Aug  8 14:21:48 host-6e-174 smartd[16858]: Opened configuration file /etc/smartd.conf
Aug  8 14:21:48 host-6e-174 smartd[16858]: Configuration file /etc/smartd.conf was parsed, found DEVICESCAN, scanning devices
Aug  8 14:21:48 host-6e-174 smartd[16858]: Problem creating device name scan list
Aug  8 14:21:48 host-6e-174 smartd[16858]: Device: /dev/sda, opened
Aug  8 14:21:48 host-6e-174 smartd[16858]: Device: /dev/sda, IE (SMART) not enabled, skip device Try 'smartctl -s on /dev/sda' to turn on SMART features
Aug  8 14:21:48 host-6e-174 smartd[16858]: Monitoring 0 ATA and 0 SCSI devices
Aug  8 14:21:48 host-6e-174 smartd[16860]: smartd has fork()ed into background mode. New PID=16860.



[root@host-6e-174 ~]# dmesg | tail -n30
lve driver register status 0
eth0: changing MTU from 1500 to 9000
ADDRCONF(NETDEV_UP): eth0: link is not ready
e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
bnx2: eth1: using MSIX
ADDRCONF(NETDEV_UP): eth1: link is not ready
bnx2i: iSCSI not supported, dev=eth1
bnx2: eth1 NIC Copper Link is Up, 100 Mbps full duplex
ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
bnx2i: iSCSI not supported, dev=eth1
bnx2: eth2: using MSIX
ADDRCONF(NETDEV_UP): eth2: link is not ready
bnx2i: iSCSI not supported, dev=eth2
bnx2: eth2 NIC Copper Link is Up, 100 Mbps full duplex
ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
bnx2i: iSCSI not supported, dev=eth2
eth0: no IPv6 routers present
eth1: no IPv6 routers present
Bluetooth: Core ver 2.10
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
eth2: no IPv6 routers present
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
Either the system was restarted very recently or the even is not logged. I'm assuming quotas need to be implemented on the server that is exporting the share.
If this is a NAS (which you mentioned) there must be a front end tool or application where you can configure quota options on it. Is there any reason why you do not want to use that and fall on quotas on linux.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial