Cannot vmotion between Intel Xeon 55xx and 56xx

tdemeyer
tdemeyer used Ask the Experts™
on
Hi,

Last week we added an extra ESX (4.1) server to our datacenter. Unfortunatly, this new machine has Intel Xeaon 5620 processors, and our two other machines have Xeon 5550.

When trying to vmotion  machines between the "old" an "new" servers, we get an error at the vmotion validation phase:
Host CPU is incompatible with the virtual machine's requirements at CPUID level 0x1 register 'ecx'
Host bits: 0000:0010:1001:1010:0010:0010:0000:0011
Required: x000:0x0x:10x1:1xx0:xx10:xx1x:xxxx:xx01
mismatch detected for these features:
* General icompatibilities

Googling for this error led me to :
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1991

This article indicates that for "Group E" type vmotion, I have to apply the AES mask...

The mask to be used is described in KB article:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1993

the article indicates I must apply mask "---- --0- ---- ---- ---- ---- ---- --0-" to level "a" (??). I found no level "a", so I assumed this meant "all" levels.

If I shutdown my virtual servers, and apply this mask to all ecx levels, I can vmotion XP's, 2000 and 2003 servers without any problem. Win7 and 2008R2 don't boot with this mask applied, they all end with a BSOD STOP error.
Trying to set up an completely new machine with this mask also ends with an blue screen during setup.

Anyone an idea how to solve this problem???
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
You should be able to select a compatible EVC Mode of one of the following, and it will set the correct mask for all procesors in your farm.

Intel® Xeon® Core™ 2
Intel® Xeon® 45nm Core™ 2       
Intel® Xeon® Core™ i7

I would select an EVC Mode of Intel® Xeon® Core™ i7, if you Cluster, and this will define the mask for all processors.

Author

Commented:
Thanks guys. This solved my problem.
I never tried creating a cluster, because I have 2 "standard" licenses, and 1 "enterprise". But it seems they can be mixed perfectly (but of course I cannot use features like DRS etc..)....

Author

Commented:
correction: 2 "advanced" + 1 "enterprise" license :)

Commented:
FYI for those of us with this same problem with valid reasons to apply an AES mask (say my E7540 vs X5680)  I figured it out. I applied the mask to level 8000000001 and level 1 and I was using vmotion very well soon after!!! note, that means I did not put the AES mask in level "0". This was in vsphere 5.0.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial