We help IT Professionals succeed at work.

rdp freezes from win 7 pro to 2003 server

KBIPRES
KBIPRES used Ask the Experts™
on
I have one win 7 pro machine that hangs when rdp'ing to a win 2003 server. It paints about the 1/3 of the first row of the screen and then hangs. It does time out on its own after a few minutes. I have no problem rdp from xp and other win 7 machines to this server.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
See if you have secure RDP turned on?

Author

Commented:
Where do I turn on/off secure RDP on a windows 7 machine? I am trying to rdp out of the windows 7 machine to a win 2003 server.
In this case don't worry about it.

The options are seen in the application window (RDP connection) click on option in the bottom left corner.

Check the experience tab and set you speed accordingly I assume you will be accessing via LAN network.

let me know if it helps

Author

Commented:
speed is set at 2 mbps - 10 mbps which is correct for this location. I tried the other speeds. No change.
And you are saying you can connect with no problems from other machines from the same location?

Try copying a RDP exec file from an XP machine and use it from the windows machine?

Author

Commented:
I can successfully rdp from my xp pro boxes to the external 2003 server that I am trying to get to. I cannot successfully rdp from  3 of my Windows 7 boxes to the external 2003 server. I am able to rdp from all my boxes to my internal 2003 servers.

I copied the rdp exec from xp to the windows 7 machine but I get the following error:
The system cannot find the file specified
c:\users\username\desktop\<lang_name>\mstsc.exe.MUI

I renamed the MSTSC.exe file in the system32 folder and put the xp version in its place. Got the same error as above.

It seems that there is something on the external 2003 server that the Windows 7 rdp client doesn't like. I saw on some google searches where the color bits were causing problems. I tried each color bit setting in the rdp options. Nothing helped.
Commented:
I solved this. It turned out that the splash screen graphic was huge. I replaced it with a small graphic and my problems have now gone away.

Author

Commented:
it wored