Accessing an Internal server using static IP address translation on a Cisco ASA5505

alltogether
alltogether used Ask the Experts™
on
Hello,

I'm trying to access an Internal remote access server from an Internet client via a browser. The network address translation works well when accessing the remote access server via a PIX 506e, but I'm receiving denial errors on the outside interface for all incoming traffic when using a new Cisco ASA5505 firewall:

2      Aug 08 2011      15:19:10      106001      81.171.191.35      28994      94.185.246.221      443      Inbound TCP connection denied from 81.171.191.35/28994 to 94.185.246.221/443 flags SYN  on interface outside

The strange thing is that when I apply an access list in the order of: ip any any on the outside interface it works fine - I can access the Internal host - but when I'm more specific and apply an access-list of: outside_access_in extended permit tcp any host 192.168.1.27 eq https I get denial errors and it's dropping all incoming IP packets.

Any help would be gratefully appreciated. Here's the firewall configuration:

ASA Version 8.2(1)
!
hostname Test
enable password cc1UObJq59rcK9uv encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.1.0 LondonLAN description LondonLAN
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.10 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 94.185.246.219 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
object-group service SRA4200_Protocols tcp
 description Outside Interface to Sonicwall SRA4200 (192.168.1.27) over permissable TCP protocols: http, https.
 port-object eq www
 port-object eq https
access-list inside_access_in extended permit ip LondonLAN 255.255.255.0 any
access-list outside_access_in extended permit tcp any host 192.168.1.27 eq www
access-list outside_access_in extended permit tcp any host 192.168.1.27 eq https
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 94.185.246.220 netmask 255.255.255.240
nat (inside) 2 LondonLAN 255.255.255.0
static (inside,outside) 94.185.246.221 192.168.1.27 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in out interface outside
route outside 0.0.0.0 0.0.0.0 94.185.246.209 1
timeout xlate 1:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http LondonLAN 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
!
prompt hostname context
Cryptochecksum:4aa7a7080e34633621a953c10152a8c3
: end
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Ernie BeekSenior infrastructure engineer
Top Expert 2012

Commented:
Try using the public address:

access-list outside_access_in extended permit tcp any host 94.185.246.221 eq www
access-list outside_access_in extended permit tcp any host 94.185.246.221 eq https

Author

Commented:
Thanks for the quick response. I've just tried inserting the revised access list but the error still persists:
2      Aug 08 2011      15:51:09      106001      81.171.191.35      37558      94.185.246.221      443      Inbound TCP connection denied from 81.171.191.35/37558 to 94.185.246.221/443 flags SYN  on interface outside

Here's the updated config file:

ASA Version 8.2(1)
!
hostname Test
enable password cc1UObJq59rcK9uv encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.1.0 LondonLAN description LondonLAN
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.10 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 94.185.246.219 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
object-group service SRA4200_Protocols tcp
 description Outside Interface to Sonicwall SRA4200 (192.168.1.27) over permissable TCP protocols: http, https.
 port-object eq www
 port-object eq https
access-list inside_access_in extended permit ip LondonLAN 255.255.255.0 any
access-list outside_access_in extended permit tcp any host 94.185.246.221 eq www
access-list outside_access_in extended permit tcp any host 94.185.246.221 eq https
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 94.185.246.220 netmask 255.255.255.240
nat (inside) 2 LondonLAN 255.255.255.0
static (inside,outside) 94.185.246.221 192.168.1.27 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in out interface outside
route outside 0.0.0.0 0.0.0.0 94.185.246.209 1
timeout xlate 1:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http LondonLAN 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
!
prompt hostname context
Cryptochecksum:4aa7a7080e34633621a953c10152a8c3
: end
Senior infrastructure engineer
Top Expert 2012
Commented:
replace: access-group outside_access_in out interface outside
with
access-group outside_access_in in interface outside

Always apply acces lists IN to an interface.
Joris VSNetwork Engineer

Commented:
access-group outside_access_in out interface outside

Shouldn't that be access-group outside_access_in in interface outside ?

Ernie BeekSenior infrastructure engineer
Top Expert 2012

Commented:
Ah, I'm not the only one who saw that ;)

Author

Commented:
That works brilliantly. Thanks so much for such a fast and professional service.
Ernie BeekSenior infrastructure engineer
Top Expert 2012

Commented:
The pleasure was all mine :)

Thx for the points.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial