Link to home
Create AccountLog in
Avatar of ecubenetworks
ecubenetworksFlag for Afghanistan

asked on

Outlook 2007 and Exchange 2010 Out of Office agent not working again....

A while back we migrated from Exchange 2003 to Exchange 2010.  Out of Office agent didnt work nor did Offline Address Book.  We got OOO agent to work, but all of a suddent a few days ago OOO stopped.  I think this goes back to an autodiscover issue, but am not too sure.

I ran the Test E-mail AutoConfiguration agent for outlook 2007 and got the following...

"Autoconfiguration has started, this may take up to a minute.
Auto configuration was unable to determine your settings!"

That's not good!

I also ran the www.testexchangeconnectivity.com
and it failed.

Nothing has changed that I know of in my domain.

Can anyone give some assistance on this one?

Thanks
Avatar of E_T_B
E_T_B
Flag of Afghanistan image

I had  this same problem.  I had to restart the Microsoft Exchange File Distribution Service on my CA server.
Avatar of ecubenetworks

ASKER

Hmmmm, worth a try!  Thanks for the idea!
Didnt do the trick.  Something must have gotten messed up with autodiscover somehow.  I dont know the best troubleshooting procedure for this since I'm a little new to Exchange 2010.
In your email autoconfig test have a look at the log tab and tell us what errors you are seeing.
Attached is 2 screen shots of the test autoconfig log...


Test-Autoconfig.docx
What happens if you ping autodiscover.marillachouse.org does it resolve internally to the internal IP address of your CAS server?
It does return the correct address of the CAS server
Try installing this on one of the failing Outlook clients:
http://support.microsoft.com/kb/2475891
I cannot seem to download the hotfix.  They send me a link in my email, then it asks for a login and password which they dont give me.  :-(
Finally got it, but that didn't do the trick...

:-(
What happens if you try this in EMS:
test-outlookWebServices "<valid user email address>" | fl
RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://ma
             il.marillachouse.org/Autodiscover/Autodiscover.xml.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1013
Type       : Error
Message    : When contacting https://mail.marillachouse.org/Autodiscover/Autodiscover.xml received the error The remote
              server returned an error: (500) Internal Server Error.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1023
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1113
Type       : Error
Message    : When contacting https://EXCHANGE01.msc.local:443/Autodiscover/Autodiscover.xml received the error The remo
             te server returned an error: (500) Internal Server Error.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1123
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1013
Type       : Error
Message    : When contacting https://exchange01.msc.local/EWS/Exchange.asmx received the error Client found response co
             ntent type of '', but expected 'text/xml'.
             The request failed with an empty response.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1025
Type       : Error
Message    : [EXCH] Error contacting the AS service at https://exchange01.msc.local/EWS/Exchange.asmx. Elapsed time was
              35 milliseconds.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1026
Type       : Success
Message    : [EXCH] Successfully contacted the UM service at https://exchange01.msc.local/EWS/Exchange.asmx. The elapse
             d time was 155 milliseconds.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1013
Type       : Error
Message    : When contacting https://mail.marillachouse.org/ews/exchange.asmx received the error Client found response
             content type of '', but expected 'text/xml'.
             The request failed with an empty response.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1025
Type       : Error
Message    : [EXPR] Error contacting the AS service at https://mail.marillachouse.org/ews/exchange.asmx. Elapsed time w
             as 171 milliseconds.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1026
Type       : Success
Message    : [EXPR] Successfully contacted the UM service at https://mail.marillachouse.org/ews/exchange.asmx. The elap
             sed time was 31 milliseconds.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1113
Type       : Error
Message    : When contacting https://exchange01.msc.local/ews/exchange.asmx received the error Client found response co
             ntent type of '', but expected 'text/xml'.
             The request failed with an empty response.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1125
Type       : Error
Message    : [Server] Error contacting the AS service at https://exchange01.msc.local/ews/exchange.asmx. Elapsed time w
             as 124 milliseconds.

RunspaceId : 9162c284-eb23-4551-b0cd-ee20021beb67
Id         : 1126
Type       : Success
Message    : [Server] Successfully contacted the UM service at https://exchange01.msc.local/ews/exchange.asmx. The elap
             sed time was 31 milliseconds.
It has to be the autodiscover service it would seem.  Not sure how to correct it though
I will give it a shot! I hope this doesnt mess anything else up in the process!  Fingers Crossed!!
It only has the potential to mess up autodiscover which isn't working too well at the moment anyway.
I did that and when i typed in the autodiscover address a login did pop up.  when I use my domain\user and password it keeps coming back.

when I just type in username and password without domain\username it says no authorization.

Is there something small i missed by chance?

Thanks...i think this is the right path!
Are you typing in the credentials for a user account that has a mailbox?
I also tried the test-outlookwebserives | fl in EMS and got "WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
'extest_42d3f21f7f204@msc.local'.
Failed to find the mailbox. Mailbox = 'extest_42d3f21f7f204@msc.local'.
    + CategoryInfo          : NotSpecified: (:) [Test-OutlookWebServices], MailboxNotFoundException
    + FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
   temConfigurationTasks.TestOutlookWebServicesTask"

:-(((
yeah, i am using my own mailbox as the test
What error do you get if you try Test-OutlookWebServices now?
so for some reason it's looking for a bunk email address of "extest_42d3f21f7f204@msc.local"

Dont know what that is
Use a valid email address with test-outlookWebServices, like I said in comment ID:36340886Author:MegaNuk3Date:08/10/11 07:39 AMYour Comment      
when i ran test-outlookwebservices domainname@marillachouse.org

all came back successfully contacted, etc.


That is the test mailbox that is normally hanging around, you can recreate them, but I can't remember how at the moment...
could there be something else in IIS that needs to be reset?
If test-outlookWebServices comes back clean against your mailbox then test from outlook. Close it if is open and then wait 15 seconds and reopen it then try and set an Out of Office message.
Of all the output from the test-outlookwebservices emailname@marillachouse.org

RunspaceId : 50ab2f9c-aa6d-4eed-b066-ef7502ae5778
Id         : 1022
Type       : Success
Message    : Autodiscover was tested successfully.

A good sign...so far i think.  Must be something else small that needs to be done.
When I startup outlook, I still get the login screen for autodiscover.marillachouse.org

when i type in my login and password it just comes back.  and Ouf of office doesnt work either.

grrrrrr
ASKER CERTIFIED SOLUTION
Avatar of MegaNuk3
MegaNuk3
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
The autodiscover settings on that page are exactly what I have...still no go.  :-(
Ok here is what i just ran into...

There are 2 url's...internal and external.

when I goto...

https://internalurl/autodiscover/autodiscover.xml \
and login now I get error 600!  This is a good thing!

What is odd is i get the idea that outlook is looking for the externalurl?  When I goto
https://externalurl/autodiscover/autodiscover.xml it wont let me in...which i think is correct.

What happens when i open outlook is the login screen is trying to login to autodiscover.marillachouse.org....which i think may be external


This the right path so far?
If you ping  autodiscover.marillachouse.org does it resolve to the internal IP of your CAS server?

If it does then add it to your Internet Explorer proxy exceptions/exclusions and then try the URL in IE again
I do ping out my internal IP of the CAS server.
Not sure what you mean by IE proxy exceptions/exclusions list in IE.  Never seen that one before.
And about every 5 minutes a login screen pops up as the autodiscover.marillachouse.org not taking my passwords.

This is irritating!  Funny how this happens out of no where.  Worked fine a few weeks ago!

Argh
Normally IE Exceptions is under Tools-->Internet Options-->LAN Settings-->proxy exceptions (depending on IE Version)
That is not there in IE9.  This morning when I startup my outlook I get a login again for autodiscover.marillachouse.org

I type in my password and it doesnt take.  I hit cancel and I cannot even open outlook now.  Could autodiscover have totally messed up opening email?  How can I get around this for the time being?
In IE9 press Alt+T to bring up the "Tools" menu
Is the internal server FQDN on your cert? If so then you can reset the autodiscoverserviceinternaluri to https://internalserverFQDN/autodiscover/autodiscover.XML

That can be achieved with following EMS command:
Get-ClientAccessServer | Set-ClientAccessServer -AutoDiscoverserviceinternalUri "https://<internalCASserverFQDN>/autodiscover/autodiscover.xml
You can also try stopping the autodiscoverappPool in IIS on the CAS server if you want a temporary workaround to actually open your mail.
no one here can connect outlook to exchange anymore.  Please help me get that back.  Not sure how autodiscover would do this since that is all I was messing with.

please help asap.

thanks
where in IIS do I stop the autodiscoverappPool?  I dont see that.
When I open outlook, it asks me for the password and references the server.local which is correct, but doesnt take.  Was doing that for autodiscover yesterday, but not this.  Must be an authentication error somewhere in IIS...but where and what?
Got outlook to work...ended up being the Exchange RPC service was stopped for some reason.  A simple reboot would have done the deal, but starting the service let everyone connect...now back to autodiscover issue...lol

round and round we go, where we stop no one knows....
Does outlook prompt for password on login now? Can you run the outlook autoconfig test successfully or not?

Did you find the proxy exceptions in IE9?
I never did find the proxy exceptions in IE9, but now out of office is working and everyone connects to exchange with outlook fine.  No more pop-up boxes...lol.

What i did find, which may be good to put in that great autodiscover white paper you wrote is to check the services.  I dialed into another client's exchange 2010 i setup and works 100%.  Only 2 services not on were POP3 and IMAP4.  Here there were numerous not on, but should have been.  once I turned those on...things started working.  

I should have considered the KISS theory right?  Keep It Simple Stupid!  LOL

Thank you so much for your help. I'm sure without your white paper on autodiscover i'd still be stuck in a hole!
This White Paper was perfect.  Only thing else to check is the Exchange Services.  Other than that this answer was 100%
Thanks for the points, don't forget to vote for my article.