Avatar of taaz
taaz
 asked on

MySql

I ran the replication and it was running good.
Now I am having problem
On the Slave I am getting either

slave_io_running: No
Slave_SQL_running: Yes

or
slave_io_running: Yes
Slave_SQL_running:No

what could be the proble I am following the exact same steps that gave me the replication
MySQL Server

Avatar of undefined
Last Comment
taaz

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
blue_hunter

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
taaz

ASKER
Slave status is incorrect command but I ran  show slave status\G;


the thing is
on the slave
stop slave;
Change Master to
 MASTER_HOST='Master IP') ,
 MASTER_PORT=3306,
 MASTER_LOG_FILE='mysql-bin.000001',
MASTER_LOG_POS=106,
MASTER_USER='repl_slave',
MASTER_PASSWORD='ABCDEF';

start slave;

show databases;
use database;
select * from table;
it does not show the insert that I made to the table in Master
taaz

ASKER
Change Master to
 MASTER_HOST='Master IP',
 MASTER_PORT=3306,
 MASTER_LOG_FILE='mysql-bin.000001',
MASTER_LOG_POS=106,
MASTER_USER='repl_slave',
MASTER_PASSWORD='ABCDEF';

start slave;

show databases;
use database;
select * from table;
it does not show the insert that I made to the table in Master
taaz

ASKER
First time i was able to see the database and table on the slave that i only created on the master.
but when i made an other insert into the table on the master it did not showed up in the same table on the slave
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
blue_hunter

Sorry , it is
Mysql > show slave status;

Any error showing when you execute the Show Slave Status ??


Your change MASTER setting looks good.
first of all, of course i would advice to check if the physical tables are tally between the master and the slave,
secondly check if the Network is enabled between the MySQL server
Third, both MySQL server are the same version ( to avoid the server have different features supported )


SOLUTION
blue_hunter

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
taaz

ASKER
the harwares and the os and the Mysql version are same.

As I mentioned earlier I was able to see the database on the slave created on the master.
but when I insert another row i to the tabel and
did the
FLUSH LOGS;
show master status\G;

and then on the slave
stop slave;

Change Master to
 MASTER_HOST='Master IP',
 MASTER_PORT=3306,
 MASTER_LOG_FILE='mysql-bin.000002',
MASTER_LOG_POS=106,
MASTER_USER='repl_slave',
MASTER_PASSWORD='ABCDEF';

start slave;

then I query the databses and table and found the tbale is not showng the insert .

blue_hunter

so, you mean your table creation query is replicated into the slave, but not the insert right ?
can have your copy of your master's my.cnf ??

let me run some test before proceed with your answer
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
taaz

ASKER
thanks