We help IT Professionals succeed at work.

PXE Booting in WDS in Server 2008 R2

Gelly77
Gelly77 used Ask the Experts™
on
I am using Server 2008 R2, i have installed WDS and am trying to set up the server for imaging Windows 7. I have added a boot image and an install image to the server. DHCP is not on the same server, so I have changed ports 66 & 67 on the DHCP server as instructed by documentation found on technet. When I boot from a client machine using the PXE boot option, I get the error PXE:E%# No Boot File Name Received. Any suggestions?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
systechSenior Technical Lead

Commented:
Have you added 060 PXEClient on scope option?

Author

Commented:
No, all the instructions I have seen have not addressed that option. Please tell me where, how and why to try that. I am not familiar with it so I am just wondering what it does.
Senior Technical Lead
Commented:
If your DHCP server and WDS server are on the same physical machine, you need to check the “Do not listen on port 67” and “Configure DHCP option 60 to ‘PXEClient’” in WDS server properties. To do this, please open WDS Server console, right click the WDS server you have added and click Properties, navigate to DHCP tap and check the above two options.

After that, WDS Server will add DHCP option 60 to the packets sent to PXE client.

There is no need to configure DHCP option 60 on DHCP server.

Have a look at this EE article http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html

Author

Commented:
Our network admin also had to make some changes on the switch.