We help IT Professionals succeed at work.

Setting up IIS 7 properly

jdouthit
jdouthit used Ask the Experts™
on
This is my first type really using IIS 7 for FTP.  I have configured the Default FTP site like I want, but I cannot connect to it using domain accounts.  The folder permissions are all correct, but I can't connect via FTP.  I'm sure there is a setting wrong somewhere that I've missed on this new version of IIS.  Any help would be appreciated.  This is being ran on a Windows 7 machine.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2016

Commented:
probably firewall settings open up the firewall and allow FTP traffic in (port 21)
how are you trying to connect ftp://computername  ??
can you login locally i.e. ftp://localhost ??
Top Expert 2016
Commented:
did you setup the authentication methods and ftp authorization rules?

Author

Commented:
I have the Windows firewall and the antivirus fireall disabled on both the FTP host machine and the connecting machine.

I did setup the authentication methods and ftp authorization rules properly.  I'm using basic authentication and allowing all users to read/write.  I followed the same steps and was able to connect just fine on a test Windows 7 machine.  I would think it is folder security, but II've even tried to connect using a domain admin account and it fails.  Domain Admins have full control of the root folder.  It is telling me login or password incorrect.
Top Expert 2016
Commented:
from the machine what do you get when you do a ftp://localhost/ ???

Author

Commented:
I receive the same results.  Login or password incorrect.
Commented:
Well, I figured out part of my problem.  Filezilla was running on this machine and taking the FTP connection before IIS could.  I have disabled Filezilla and am running into the following problem now.

C:\Users\user1>ftp hostmachine
Connected to hostmachine.domain.local.
Connection closed by remote host.
Commented:
I resolved the last issue.  I assigned a specific IP.  Because of this I could connect using IP, but not hostname.  I changed this to all unassigned addresses and could then connect using hostname.

Author

Commented:
My solution was what fixed the issue.  It was an odd solution with outside interference due to Filezilla.  All points were still awarded to ve3ofa for their help.