PDF Documents opening in IE 8 or IE 9 using Windows 7

nherrington
nherrington used Ask the Experts™
on
I have users using Windows XP / IE 8 and this works fine.  However my Windows 7 / IE 8 or IE 9 it does not work.

They go to a web site and the site allows them to pull up reports that are in PDF format.  There is no way to save the document only to view.  It pops open a new browser window and displays the PDF.

If I log in as an adminstrator the application works fine.  However, my normal users it will not display the PDF.  With this said I'm assuming that it is trying to access a file or directory that normal users can't access.  My question is what files is the PDF plugin accessing to work?

Thanks in advance for the assistance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
It should work with a regular user. Acrtobat updated to the latest?
Not a fix but should work unless Acrobat simply isn't allowed for non-admins. Maybe a GPO setting?

http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/cannot-display-online-pdf-files-in-ie8windows-7/d5accc98-cba7-45db-a6f0-ea6d59a6a249

You need to go into Adobe Reader preferences and in the internet section, uncheck the "display in browser" option. The net effect will be to open a pdf in a new window outside of the browser.

Hope this works for you

Author

Commented:
Yes, adobe is fully updated.

Found a similar arcticle about unchecking the 'display in browser' ... did not do any good

Thanks for the comments.
So a non-admin simply can't run Acrobat Reader, correct? Some sort of GPO in effect?

Author

Commented:
No, they can open reader and open local PDF's.
It simply won't open PDF's through IE 8 or IE 9
Login as a Domain Admin or simply a local admin and it works fine

Thanks!!

Author

Commented:
Any more ideas?
I have a local admin that pulls all the same GPO's and it works fine.  It works fine in WinXP as a regular user.
Something about Win7 is restricting a file or something to allow this to open.
Maybe try reloading Acrobat as an admin for all users.

Author

Commented:
Can you elaborate on that approach a little?
I have actually tried giving full access to the adobe directory and the adobe files found in common files.  
It restricted me from doing so.
Just use Programs & Features to uninstall Adobe Reader, reboot, install Adobe Reader. If it asks for all users then say yes.
Also this should work as your users can open Acrobat manually.

You need to go into Adobe Reader preferences and in the internet section, uncheck the "display in browser" option. The net effect will be to open a pdf in a new window outside of the browser.

Author

Commented:
Neither solution worked.
What happens when you click a pdf with the "display in browser" option unchecked? Does the setting revert back to checked?
You probably need to close all IE windows after unchecking then restart IE.

Author

Commented:
Let me throw some more info into the bag ...

Downloaded and installed a fresh standard version of FireFox 6.0 ... works like a charm .. go figure

Seeing some weird behavior ... looking a URL links from one that works and one that doesn't it appers that IE is dropping the login connection
Any ideas on what would be causing that?  Again, admin login works where user login doesn't
I can believe the strangeness from IE9 but IE8 is pretty stable.

What happens when you click a pdf in IE 8 with the "display in browser" option unchecked? Does the setting revert back to checked?

Author

Commented:
I'm testing mainly on a box with IE 8, because I know of all the problems with IE9 that are still out there

When I click the view button another browser windows open and adobe never does open

Checkbox for display in browser is still unchecked when I manually open adobe to see
OK and you closed all browser windows before clicking, right? Maybe try a reboot.

Author

Commented:
Yes, I actually didn't open the browser before I made the changes.  Already rebooted.
maybe it's something like this

Their issue was with Outlook but the temporary folder for IE might be your problem. You could also try clearing everything in cache or just logging on as another non admin user that hasn't been on that PC.

http://social.technet.microsoft.com/forums/en-US/exchangesvrclients/thread/c58ac4a5-16b7-4531-973d-30229ba29e5c/

Similar to the previous post, I resolved by doing the following:

    1. Open REGEDIT.EXE and go to Edit -> Find... In the Find dialog box type "OutlookSecureTempFolder" without the quotes and locate that registry key.

    2. That key will contain the actual folder location, and will look like:

      C:\Documents and Settings\%USER_NAME%\Local Settings\Temporary Internet Files\OLK#\ (where # is a random letter or number)

    3. Copy the location of that folder.

    4. Click on Start -> Run... and paste the folder location from step #4 then click OK.

    5. Windows Explorer will open that folder. Please, delete all files present.

    6. Restart Microsoft Outlook and you should be able to open your attachments.

Author

Commented:
New computer ...
Unchecked pdf in browser
Restarted the computer
Clicked on View PDF .. new browser window opens and nothing ...
Same thing.
How about if you log on as a local user rather than domain?

Is this a clone?

Author

Commented:
Local user is working ... now to only add more mystery to the game
OK then it has to be GPO. See if you can find anything in it about Acrobat.
or IE

Author

Commented:
Problem is .. my local admin's that work are pulling the same GPO as my users.  Only difference is they are local admins on that machine.
Your GPO can restrict users from running programs. Maybe it's something like this.

http://support.microsoft.com/kb/323525

It's Windows 2000 but probably similar for what you are running. Since it's only under IE I would look at any settings for that. Maybe it's only Win7 IE8/9 that actually does as the GPO is asking.

There is definitely soemthing odd going on with your GPO.

Editing the Group Policy in a Domain
To edit a domain-wide policy to restrict users from running specific Windows programs:
Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
Right-click your domain, and then click Properties.
Click the Group Policy tab.
In the Group Policy Object Links box, click the group policy to which you want to apply this setting. For example, click Default Domain Policy.
Click Edit.
Expand User Configuration, expand Administrative Templates, and then expand System.
In the right pane, double-click Don't run specified Windows applications.
Click Enabled, and then click Show.
Click Add, and then type the executable file name of the program that you want to restrict users from running. For example, type iexplore.exe.
Click OK, click OK, and then click OK.
Quit Group Policy Object Editor, and then click OK.

Author

Commented:
The only thing I'm finding is under one of my policies

IE > Computer Configuration > Admin Templates > Windows Components > IE > Security Features > Restrict File Download

All three were enabled.  I have turned off all three and gave it time to push out.  Still getting same results.
You could try creating a new group with the edited GPO copied over under a new name. Then login with a new user in that group.

Author

Commented:
Any more updates or suggestions?
You might try uninstalling IE8 and re-installing. Maybe it will pick up Acrobat.

Curious why you would have issues with the following. This folder is on the local machine, right? There should not be any restrictions if you are an administrator.

I have actually tried giving full access to the adobe directory and the adobe files found in common files.  
It restricted me from doing so.

Author

Commented:
Yes, the folder is on the local machine.
Windows 7 and their 'security' have really goofed a lot of stuff up.  Some programs that ran fine in XP, I have eneded up having to give users 'full access' to the folder from them to run.
You could always try XP Mode to see if it makes a difference.

I still think it's GPO since local security is fine with loading Acrobat.

Author

Commented:
I'm leaning towards a directory or file that can't be accessed.  
The reason being is because a user that pulls all the same GPO's and runs through the same proxy can access it.  The ONLY difference is they have admin rights to their local machine.
Plus, I have combed through all my GPO's numerous times and can't find anything that would cause issues.
But you logon as a non-admin and it works, right?

Author

Commented:
No, logged onto the domain no non-admin works
non admin on Local Machine not domain
I got this to work on one computer, I want to try it on another I was  having trouble with before I celebrate to much.
Not sure what I did as I made several changes.  End result was I deleted the profile and recreated it on the computer that it is working on.
GPO change worked?  Something stuck in the profile?  
Only problem is I put the GPO that I changed back to orginal state since it didn't seem to help.  
Profile?  Maybe, but would not think that multiple profiles were corrupt.

Thanks for all the input and ideas.  I will let you know if I'm sucessful on another computer.

Author

Commented:
I'm not sure the GPO was ever the problem.  Everything I changed I changed back to the original state.  I'm really not sure what happen.  I changed and took a lot of steps from the help I received.  However, when I deleted the profile and let it recreate it started working.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial