windows could not start the Computer Browser. error 1058

Hello All,

I have installed Windows 2008 R2 on a new machine and when I try to start the "Computer Browser" service I get the following error:

Windows could not start the Computer Browser service on local Computer, Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

I have checked the service and is not disabled. Also, checked the dependencies (Server and Workstation) services and they both started.

Thanks in advance.
skemptonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Double check permissions on the following reg key.....

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\browser

SYSTEM /Administrators "Full Control"; Users "Read".....

skemptonAuthor Commented:
I have checked the regkey and the permissions are there.
abhijitwaikarCommented:
Hi,

Verify below setting under SERVER SERVICE.

-Open the properties of the server service and select the LogOn tab.
-Verify that the service has not been disabled for the hardware profile that you are using. If it has, click Enable.
-Click on the general tab.
-In Startup type, verify that the service has not been. If it has, click Automatic to have it start when you start the computer.

KB Article:Service Does Not Start and Displays "Error 1058"
http://support.microsoft.com/default.aspx?scid=kb;[LN];241584

Once the server service is started, please try to start the computer browser service.

Regards,
AbhijitW

Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

skemptonAuthor Commented:
I have tried the steps in the provided KB article and that did not resolve the issue.
MazdajaiCommented:
Is firewall running? If so, disable it temporary for troubleshooting purpose.
skemptonAuthor Commented:
Firewall is disabled.
skemptonAuthor Commented:
Thanks all for you comments and replies. I was able to resolve the issue. I think the service was stuck, all I did is the following:
1. Set Startup Type: Disabled ten clicked Stop then OK
2. Set Startup Type: Automatic, clicked Start then OK

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
skemptonAuthor Commented:
The steps resolved my iussue
skemptonAuthor Commented:
The provided steps resolved my specific issue.
PalaceitCommented:
Accepted Solution from OP above worked for me.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.