windows could not start the Computer Browser. error 1058

skempton
skempton used Ask the Experts™
on
Hello All,

I have installed Windows 2008 R2 on a new machine and when I try to start the "Computer Browser" service I get the following error:

Windows could not start the Computer Browser service on local Computer, Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

I have checked the service and is not disabled. Also, checked the dependencies (Server and Workstation) services and they both started.

Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2011
Top Expert 2011

Commented:
Double check permissions on the following reg key.....

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\browser

SYSTEM /Administrators "Full Control"; Users "Read".....

Author

Commented:
I have checked the regkey and the permissions are there.
Hi,

Verify below setting under SERVER SERVICE.

-Open the properties of the server service and select the LogOn tab.
-Verify that the service has not been disabled for the hardware profile that you are using. If it has, click Enable.
-Click on the general tab.
-In Startup type, verify that the service has not been. If it has, click Automatic to have it start when you start the computer.

KB Article:Service Does Not Start and Displays "Error 1058"
http://support.microsoft.com/default.aspx?scid=kb;[LN];241584

Once the server service is started, please try to start the computer browser service.

Regards,
AbhijitW

Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Author

Commented:
I have tried the steps in the provided KB article and that did not resolve the issue.
Is firewall running? If so, disable it temporary for troubleshooting purpose.

Author

Commented:
Firewall is disabled.
Commented:
Thanks all for you comments and replies. I was able to resolve the issue. I think the service was stuck, all I did is the following:
1. Set Startup Type: Disabled ten clicked Stop then OK
2. Set Startup Type: Automatic, clicked Start then OK

Author

Commented:
The steps resolved my iussue

Author

Commented:
The provided steps resolved my specific issue.

Commented:
Accepted Solution from OP above worked for me.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial