We help IT Professionals succeed at work.

sbs 2011 outgoing emails

ssiremote
ssiremote used Ask the Experts™
on
sbs 2011 is the dc. i use exchange pop3 for my incoming at outgoing emails. www.kinesphere.com. the smarthost was never setup since exchange pop3 handles it inhouse. initially a hosting company "abc.cm" was hosting my web page and emails hence my smtp was configured as "mail.abc.com".all was good until  recently have switched to another hosting company called xyz.com . the outgoing server in exchange pop 3 was changed to "mail.xyz.com". now i cant send outgoing emails. have checked with xyz and have confirmed the smtp is coorect. issue is never mind the outgoing the email  address im using to authenticate the smtp server will not authenticate. i figured i should try the isp's "cabblecompany.com" smtp and that will not authenticate either. hope im not confusing you folks wiith my post . any help will be appreciated. thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
have you checked with the isp to see if they now block port 25, because I assume since everyone is sending to the exchange server you are smarthosting through xyz.com. have you changed the send connector to the new smarthost?  are the pop/smtp accounts all authenticating through your exchange server or through the xyz.com?  
Top Expert 2013
Commented:
You are confusing us, or at least me :-)
The pop connector is used for collecting incoming mail but has nothing to do with outgoing e-mail. ssuming you are using Exhange to send mail you have 2 options DNS, or smarthost. As a rule with SBS if you don't have proper reverse DNS record set up an/or you have a Dynamic IP, you should use a smarthost. The choice of using DNS or smarthost is configured by running the CEICW (Server management | Internet and e-mail | connect to the internet). However it sounds more like you have configured each e-mail client, within Outlook, to use a remote SMTP server, which is not a recommended configuration.

Author

Commented:
@madhatter5501: yes i have checked with the isp and they are not blocking port 25. i have verified that cause if i change the smtp back to mail.abc.com it immediately starts sending outgoing emails. i change it to mail.xyz.com and it stops sending. funny part is if i setup the emails on the workstations as pop accounts and not exchange then all is good. so something is messing up in my exchange. thanks
I would do like said above and check with the isp about a ptr record for your reverse dns and use the dns feature built into the exchange send connector.  or use the isp as the smarthost.  you don't need to use the webhosting for email if you have your own exchange server.

Author

Commented:
@robwill. yes i think ive confused u with my explanation. no pop connector is confused, i use a program called exchangepop3 www.kinesphere.com that replace the native sbs pop3 connector.
Top Expert 2013

Commented:
Why?

Author

Commented:
its very clean and very very easy to configure. i prefer it to the native pop connector.

Author

Commented:
hmmmm. puzzled. setup a gmail account a@gmail.com. set smtp as smtp.gmail.com and used the a@gmail.com as authentication and that worked. very confused. tinkering further
sounds like a config issue with the xyz.com then or maybe the xyz.com doesn't support that kinda setup?

Author

Commented:
@madhatter5501: i think you are correct. see attached smtp settings page in exchangepop3
have you checked to see if they support ssl and that port is correct?

Author

Commented:
they do not. i was using port 25 when xyz.com was the smtp. as a matter of fact a tech from the hosting co showed up at my office and tried all kinds of stuff but could not figure  it out. i switched to ssl a few mins ago when i used gmail as the outgoing.
have you tried turning off smtp auth?

Author

Commented:
yep tried that. no joy
sometimes mail authentication can be quirky, try setting per instructions and let sit a day and maybe will work.  I have seen that before where things will just start working for no apparent reason.  or, did they change the password for you, does that take time to replicate in their systems?

Author

Commented:
no password change. will follow your advice and sit tight for 24 hours. maybe it will start working. will followup with postto keep you guys updated. thanks for all the help
no problem, hope you get it workin
Top Expert 2013

Commented:
I am starting to see why I was confused. You had mentioned "the smarthost was never setup ", yet if you send mail using another smtp server such as smtp.gmail.com, that is what a smart host is. So, effectively you are using a smarthost. Also you cannot send mail via POP/POP3 but I see now you have an add on named "Exchange POP3", through which you are sending e-mail. I didn't catch that before.

I apologize for my confusion, and not being familiar with that application I may not be of much help. However:

Can it be a DNS issue. From the "Exchange POP3" server can you resolve the new host name? Check from a command line using
nslookup mail.xyz.com

As mentioned you are using mail.xyz.com  as a smart host. Does "Exchange POP3" updates this configuration within Microsoft Exchange?

Author

Commented:
@robwill : thanks for your help. am currently exploring the dns option with email host company. also , i meant to say that i have not setup the native samrthost using the wizard. sorry about that
Top Expert 2013

Commented:
No need to apologize the confusion was on my end. I was just explain why.

In addition to DNS my last comment doesn't look that clear to me now. Because you are sending mail out through mail.xyz.com, Microsoft Exchange needs that updated information. Does your "Exchange POP3" application make that change for you when you update it?

Author

Commented:
all right guys, issue fixed. the error was on the hosting company side. they figured out that they were blocking my public ip. thank you guys for all your help
Top Expert 2013

Commented:
Thanks ssiremote. Glad to hear you have it resolved.
Cheers!
--Rob