SBS2008 Windows Installer seems to be broken and unable to fix

StuartSanders
StuartSanders used Ask the Experts™
on
I'm having a problem with a clients SBS server and despite numerous hours looking into this have not found a solution.

Basically Windows Installer or some component of it seems to be broken.  When installing a number of programs, the installation process just hangs.  No errors, just stops and the install process runs at 100% cpu on one core.  I can leave it for days and it just conintues in this manner.  Never completes and never throws an error until I terminate it or restart the machine.

Doesn't happen with all installations but most, including some MS install programs.  Restoring is not really an option, though I did try to migrate to another machine using SBS 2008 migration, but can't run the migration wizard - it hangs like other install programs...

I'm willing to give pretty much anything a go at this point even revisiting things I've tried which is why I won't go into the list of what I have tried in any great detail as I may have overlooked something.

I can say the latest thing I tried was to try running .Net 3.5 SP1 maintenance mode - hung running for several days.

So in order of preference -
- fix the issue somehow
- get the migration wizard to run and I'll transfer everything over to another machine.  (In fact I may do this regardless)

-S
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Did you check event logs? What does it say?

Anyways, First of all download the latest Windows installer from Microsoft

http://support.microsoft.com/search/default.aspx?qid=407&query=windows+installer+4.5&catalog=LCID%3D1033&mode=r 

And try the installation,  you may also try Cleanup utility to clean previous infant installations.

http://www.softpedia.com/get/Security/Secure-cleaning/Windows-Installer-CleanUp-Utility.shtml 

Then do a reboot and try installing your application again, make sure you have ADMIN rights.

Hope this helps.

Author

Commented:
Unfortunately trying Windows6.0-KB942288-v2-x64 returns a message "The update does not apply to your system".

The cleanup utility helps uninstall stuff from my understanding, but I'm not sure how that would help install something.

Commented:
The cleanup utility will cleanup your incomplete/improper previous installations.  Before you start a new installation, it is always advised to clean the mess...

Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Commented:
You may try SBS Best practice analyzer to get some more information.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=6231

Commented:
Try all these,
 
1. Go to "Start" -> "Run”, type "services.msc" and press on "Enter" button.
2. Double-click on the service named "Windows Installer".
3. Check the value in the "Startup type:" field. If it's currently set to "Disabled", then this is the
    problem. Change it by selecting "Manual" from the drop-down box and also make sure that     the service is started.
 
If the above step does not fix the issue would suggest that you try to unregister Windows Installer, and then reregister Windows Installer. To do this, follow these steps:
 
1. On the "Start" menu, click "Run:.
 
2. In the "Open" box, type "msiexec /unreg", and then press ENTER.
 
3. On the "Start" menu, click "Run".
 
4. In the "Open" box, type "msiexec /regserver", and then press ENTER.
 
 
For more information refer the below link.
How to resolve Common "Windows Installer" Problems

http://support.microsoft.com/default.aspx/kb/555175
 
 
The error message that you receive while installing the Windows Installer cleanup utility to due to with the User Account Control (UAC) enabled in Windows Vista, you may be denied write access to the Program Files directory and its sub-directories by default. The error above occurs when the Windows Installer Cleanup Utility's setup script (StartMSI.vbs) attempts to copy the extracted files from the Temporary folder to the C:\Program Files\MSECache\WICU3 folder.
 
To resolve the problem, you need to install the Windows Installer Cleanup Utility as administrator. To do so, right-click the setup file (msicuu2.exe) and choose Run as Administrator. If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
 
Unfortunately none of these seem to work.  

The only thing I didn't try too far was msicuu2.exe, as I do not want to break anything that currently works.

Looks like its time for a brand new install and manual migration of all data, email and PCs.

Author

Commented:
No objections to the close request.  

Actual steps taken:
- physical to virtual conversation on temp server
- reformat original server
- installation and migration of old server to new server.  Some issues with this as even some of the migration tools could not be installed/run but worked out in the end.

Stuart

Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial