Link to home
Create AccountLog in
Avatar of landiiiks2
landiiiks2

asked on

Certificate Mismatch in Outlook 2010

This company has recently migrated from Exchange 2003 to 2010.  There is an SSL certificate in place, and appears to be working properly.  There are about 40 users and all except one get no errors and no issues with autodiscover, etc.  There is one user who has gotten a new laptop since the migration.  It has Windows 7 and Outlook 2010 (I should mention that many other users in the office also have that combination).  This user only is getting the "The name of the security certificate is invalid or does not match the name of the site" when opening Outlook.  It says it is looking for "remote.domain.com", which is what SBS names everything by default, but everything has been changed on Exchange to "mail.domain.com."  And again, NO other user out of about 40 is having an issue.  I have deleted the mail profile, deleted all the settings, and recreated the profile, but I still have this issue.  I have done the Autodiscover test within Outlook, and it passes.  I have done the www.testexchangeconnectivity.com test and it passes.  DNS server settings are all the same as everyone else (DHCP).  What could be different about this one computer that is causing the error?  She can agree to the message and use Outlook normally, but I still need to resolve the error.  Thanks!
Avatar of MegaNuk3
MegaNuk3
Flag of United Kingdom of Great Britain and Northern Ireland image

In the outlook autoconfig test, does it show any URLs that mention remote.domain.com ?
Avatar of landiiiks2
landiiiks2

ASKER

No.  It was originally showing that for Exchange over HTTP, but they aren't using that, and I fixed it anyway.  The autoconfig test produces exactly the same results on this computer as on one that isn't getting the error.
ASKER CERTIFIED SOLUTION
Avatar of pcchiu
pcchiu

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Rebuilding the profile worked.  I have no idea why, but it did!  Thanks!