Link to home
Create AccountLog in
Avatar of hundet
hundet

asked on

Office and IE slow in Citrix

We have recently upgraded our user client machines with Office 2007 (from Office 2003).  We HAVE NOT upgraded our Citrix 4.5 servers - they are still running Office 2003.  When users run a published app from Citrix, the app launches, but then just sits there for about 5 - 10 minutes before the user can do anything.

If that same user goes to a machine that has not been upgraded to Office 2007, everything works fine on the Citrix side.

I've read a bunch of info about slow response times with Office 2007 SP1 on Citrix, but in our case we have not upgraded our Citrix servers.

Anyone have any ideas?
Avatar of joharder
joharder
Flag of United States of America image

By chance, do you or have you ever run Citrix streamed apps within your environment?  Older versions hijacked the file type associations and that may be coming back to bite you now.  It would take forever for the system to realize that the streamed was no longer installed.
Avatar of hundet
hundet

ASKER

Nope - we've never used streamed apps - just published apps.
I do not think it's due to client office software. To confirm on the same, run any other apps like notepad from the same server as office. Test performance from both the machines. If still the same problem, then check the slow machine has many printers in local printers and faxes.  Also are those pcs are in same network?
Avatar of hundet

ASKER

I didn't believe it was client version of Office at first either.  However, we have two identical machines, with the same base Windows XP SP3 image, with identical printers installed.  One has Office 2007 and the other has Office 2003 installed locally on the client.  We only have 1 Citrix server that has Office apps on it, so I know everyone is using the same Citrix version of Office 2003.  Using the same user account to login to the network here are the results.

If the client machine with Office 2003 runs the Citrix version of IE or Excel everything runs normally.
If the client machine with Office 2007 runs the Citrix version of IE or Excel, the app launches, but immediately after it opens, it hangs for 3 - 5 minutes.

We've also noticed the same slowness with non Office applications, but again only on the client machines that have been upgraded to Office 2007.

I'm thinking about exploring Application Isolation on the Citrix server, hoping that might help.
Don't go down the App Isolation road if you don't need to.  Are you sure that you never installed the Citrix Offline (formerly Streaming) plug-in?  The behavior you're describing sounds like exactly what happens when you do and file type associations get hijacked.

Are you using content redirection?  

Nonetheless, take a look at File Type Associations on both the server and the client machine.  It also could have something to do with the "x" at the end of .doc, .xls, etc., that was added in Office 2007 and/or the templates.  
ASKER CERTIFIED SOLUTION
Avatar of hundet
hundet

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of hundet

ASKER

Found solution on my own.