Link to home
Start Free TrialLog in
Avatar of svetoslavm
svetoslavmFlag for Canada

asked on

Cannot start Java MicroEdition Emulator

Hello,

I am following these simple steps from
http://netbeans.org/kb/docs/javame/quickstart.html

and I cannot start the emulator.
See the attached files for more info.

this is the line that causes the error.
    <target name="cldc-run" if="cldc-platform.trigger">
        <nb-run jadfile="${dist.dir}/${dist.jad}" jarfile="${dist.dir}/${dist.jar}" jadurl="${dist.jad.url}" device="${platform.device}" platformhome="${platform.home}" platformtype="${platform.type}" execmethod="${run.method}" securitydomain="${evaluated.run.security.domain}" commandline="${platform.runcommandline}" classpath="${platform.bootclasspath}:${dist.dir}/${dist.jar}" cmdoptions="${run.cmd.options}"/>
    </target>



 netbeans-out-xp-and-win7.txt

 netbeans-build.txt
 
C:\jdk_1.7.0\bin>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)

Open in new window

SOLUTION
Avatar of for_yan
for_yan
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of svetoslavm

ASKER

I've added nebeans and a file from the mobility folder to exceptions.
still no change.
I've tested it on XP 32bit, still not working
Do you know what they mena by this:
"i only went to Tool/java platforms and refresh the Java Platform Micro Edition"
the refresh returned: "Configuration Failed" (both under Win 7 and XP)
I see, so there is some failure with  Java Platform Micro Edition not just with Emulator
Any other diagnostics when it says "Configuration failed" ?
ASKER CERTIFIED SOLUTION
Avatar of CEHJ
CEHJ
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yeah, installing an older version made the emulator to show up.
thanks everyone.
:)