Link to home
Start Free TrialLog in
Avatar of Chris Millard
Chris MillardFlag for United Kingdom of Great Britain and Northern Ireland

asked on

550 Requested action not taken: mailbox unavailable / 5.7.1 Unable to relay

I've recently switched my email to Google's Postini service (literally only about 2 days ago). I've modified my MX records so that my inbound emails now go through their SMTP servers then get pushed to mine.

However, my Outbound emails from my Exchange server, as of yesterday, are not going out. I've not made any changes to my outgoing mail - they still go through the same smart host.

When I telnet to my Exchange server from outside of my network, the helo command works, and the mail from command is OK, but when I use rcpt to: <email> command, I always get the following message:-

550 Requested action not taken: mailbox unavailable

If I telnet to the Exchange server from inside my network (even on the server itself), when I use the rcpt to: command, I get

550 5.7.1 Unable to relay

Any ideas please? Nothing has changed on this server in the past couple of years, so I don't understand why it's doing this now!
Avatar of the_endjinn
the_endjinn
Flag of United Kingdom of Great Britain and Northern Ireland image

Hiya,

Is there any reason that you aren't using the Postini smarthost for outbound, or why you haven't configured private outbound DNS on Exchange instead which is the preferred method, you get individual queues etc but everything resolves to Postini.

Also, apart from changing the MX records are you confident nothing else at all has changed?
I would definitely recommend reading the following as it's very clear, concise and useful. It gives steps for the vast majority of setups on various versions of exchange.

http://www.postini.com/webdocs/outbound/en/outbound_config_en.pdf
Are you trying to send to external email or internal?
Do you have the full header of the bounced back message?
Avatar of Chris Millard

ASKER

The reason I don't (can't) use Postini for outbound is that I'm on a dynamic IP.
I'm also positive that nothing else has changed other than the MX records themselves.
@goraek. If I send internally, everything works fine - it's just when sending externally. There is no bounceback as of yet, I'm getting messages from exchange to say that the emails have been delayed. But it's when I telnet to the server that I can see the exact errors.
What exchange version are you running?

And what happens when you send an email to your hotmai or gmail account?
I'm running Exchange 2007 as part of SBS, and it doesn't matter WHAT external email account I send to - none of them get through, they are all sitting waiting to retry.
Check your Send and Receive Connectors
Also check your permissions - Authentication and Permission Group
Done that already. Nothing has changed
Using the Queue Viewer, I am seeing the following which I hadn't noticed before:-

451 4.4.0 Primary target IP address responded with: "451 5.7.3 Require basic authentication." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

If I switch to using DNS, then the mails go out, but a lot of remote mail servers don't accept emails from my server directly.
So you can't use private outbound DNS as you are on dynamic IP? How do you get mail in on dynamic?

Also, have you checked that the authentication on exchange and your smarthost is set to anonymous?
I get my mail in by modifying the DNS records for my domain. I have a DNS CNAME entry of remote.mydomain.com which points to a no-ip.org address which is in turn dynamically updated and this works perfectly.

The authentication is (and always has been) set to BASIC because outbound email goes through my web host - not my ISP.
It might be worth confirming with the company providing the smarthost that the credentials are correct. Also, have you tried with blank credentials, or with anonymous auth on your send connectors?

Also, you are using a smarthost because people don't accept mail from you direct, do you know why they won't accept? Is it lack of spf records due to the dynamic IP? Alternatively, have you considered requesting a static IP from your ISP as SMTP on dynamic isn't really best practice.
Static IP on my account is just too expensive compared to what I'm paying now. I get a good deal. As for the smarthost, I have a reseller account, so I'm hosting my own, and I know full well that the credentials are OK.
I'm not sure what else to advise I'm afraid as the "451 5.7.3 Require basic authentication." usually means that either your send connector to the smarthost, or a setting on the smarthost, aren't correct. Are you using spam filtering, non-standard ports or something on the smarthost? Has anything on the network, such as new devices, routers, firewalls, changed between the exchange box and smarthost? If no to all the above then hopefully someone with more knowledge will come along and help you out.
ASKER CERTIFIED SOLUTION
Avatar of Chris Millard
Chris Millard
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
My MX records were changed from mydomain.com to s200a1.psmtp.com, s200a2.pstmp.com, s200b1.psmtp.com and s200b2.psmtp.com

Since the MX records fully propagated, that seems to have been when the problem occurred.

As a test, I re-added mydomain.com as an MX record, but gave it the lowest priority. Since re-propagating, the smarthost is now working!
OMG thought you said you changed your MX records? LOL
I did. I said that the MX records had been changed when I subscribed to the Postini service. I didn't reaslise that removing mydomain.com from the MX records and just leaving the Postini ones would cause a problem