We help IT Professionals succeed at work.

Cisco Router 887VA, VDSL2 PPPoE client connection problems

Robin_Ottawa
Robin_Ottawa asked
on
Hello everyone,

I bought a Cisco 887VA router, which has an integrated VDSL over POTS modem.. I'm trying to configure it now, but running into some trouble.. here's my running config :

configuration : 1848 bytes
!
! Last configuration change at 22:41:36 UTC Tue Aug 30 2011
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 887va
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$EkTc$OSnplp9ibT8ZFL2iDgY.u.
enable password ___
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
!
ip source-route
no ip routing
!
!
no ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
 request-dialout
  protocol l2tp
!
license udi pid CISCO887VA-SEC-K9 sn _____________
!
controller VDSL 0
!
!
interface Ethernet0
 ip address dhcp
 no ip route-cache
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 no ip route-cache
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 shutdown
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 switchport access vlan 100
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan100
 ip address 10.0.0.5 255.255.255.0
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname _______@copperdsl.ca
 ppp chap password 0 ________
 ppp pap sent-username ________@copperdsl.ca password 0 _________
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
logging esm config
access-list 1 permit any
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password ______
 login
 transport input all
!
end

Open in new window


I know the modem is working, as the CD (Carrier detect) light is on, and I am getting line stats like below :

 
a#sh controller VDSL 0
Controller VDSL 0 is UP
 
Daemon Status:           Up
 
                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'BDCM'
Chip Vendor Specific:   0x0000                   0xA194
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   'BDCM'
Modem Vendor Specific:  0x4602                   0xA194
Modem Vendor Country:   0xB500                   0xB500
Serial Number Near:    FGL151222YQ 887VA-SE 15.1(2)T
Serial Number Far:
Modem Version Near:    15.1(2)T
Modem Version Far:     0xa194
 
Modem Status:            TC Sync (Showtime!)
DSL Config Mode:         AUTO
Trained Mode:            G.993.2 (VDSL2) Profile 12a
TC Mode:                 PTM
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running
Trellis:                 ON                       ON
Line Attenuation:         0.0 dB                  0.0 dB
Signal Attenuation:       0.0 dB                  0.0 dB
Noise Margin:            39.8 dB                 24.3 dB
Attainable Rate:        92444 kbits/s            27229 kbits/s
Actual Power:            14.5 dBm                -18.5 dBm
Per Band Status:        D1      D2      D3      U0      U1      U2      U3
Line Attenuation(dB):   3.5     7.5     N/A     1.9     6.7     7.9     N/A
Signal Attenuation(dB): 3.5     7.5     N/A     0.0     6.1     6.8     N/A
Noise Margin(dB):       39.6    39.8    N/A     24.5    24.1    24.5    N/A
Total FECS:             0                        0
Total ES:               0                        0
Total SES:              0                        0
Total LOSS:             0                        0
Total UAS:              0                        0
Total LPRS:             0                        0
Total LOFS:             0                        0
Total LOLS:             0                        0
Bit swap:               0                        0
 
Full inits:             1
Failed full inits:      0
Short inits:            0
Failed short inits:     0
 
Firmware        Source          File Name (version)
--------        ------          -------------------
VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)
 
Modem FW  Version:      100608_1515-4.02L.03.A2pv6C030h.d22k
Modem PHY Version:      A2pv6C030h.d22k
 
                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            26941             0              8127
Previous Speed:           0                0             0                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Interleave (ms):       0.00             0.00          0.00              0.00
Actual INP:            0.00             0.00          0.00              0.00
 
Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

Open in new window


the stats look great, as I seem to have the correct speed profile.. I just cant figure out how to establish a pppoe connection..  everything I read online is saying this :
vpdn-group 1
 request-dialout
  protocol l2tp

Open in new window

should be:
vpdn-group 1
 request-dialout
  protocol pppoe

Open in new window

but the IOS doesnt let me enter it... l2tp is my only option..

also i tried entering "bba-group pppoe global" and then "pppoe enable group global" on Ethernet0, but no matter what "pppoe enable" command I enter for Ethernet0, it never saves it...
Comment
Watch Question

Top Expert 2014
Commented:
Try something like this...

conf t
controller VDSL 0
interface Ethernet0
 no ip address
 exit
interface Ethernet0.10
 encapsulation dot1Q 10
 pppoe enable group global
 pppoe-client dial-pool-number 1
 exit
interface Vlan 100
 ip address 10.0.0.5 255.255.255.0
 ip flow ingress
 ip nat inside
 no ip virtual-reassembly
 ip route-cache policy
 ip tcp adjust-mss 1452
 exit
interface Dialer1
 description VDSL <NAME-ISP>
 mtu 1492
 ip address Negotiated
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 ip route-cache policy
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username <username> password <password>
 exit
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
access-list 100 permit ip 10.0.0.0 0.0.0.255 any
ip nat inside source list 100 interface Dialer1 overload
end

Open in new window

Author

Commented:
no luck.. here is the new running config... the 'pppoe enable group global' still won't stick to Etherner0.10 !!

Current configuration : 1859 bytes
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 887va
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$EkTc$OSnplp9ibT8ZFL2iDgY.u.
enable password ___________
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
ip source-route
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
license udi pid CISCO887VA-SEC-K9 sn FGL151222YQ
!
controller VDSL 0
!
bba-group pppoe global
!
!
interface Ethernet0
 no ip address
!
interface Ethernet0.10
 encapsulation dot1Q 10
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 shutdown
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 switchport access vlan 100
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.0.0.5 255.255.255.0
 ip flow ingress
 ip nat inside
 no ip virtual-reassembly in
 ip route-cache policy
 ip tcp adjust-mss 1452
!
interface Dialer1
 description VDSL teksavvy
 mtu 1492
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 no ip virtual-reassembly in
 encapsulation ppp
 ip route-cache policy
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username ________________ password 0 ________
 no cdp enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
!
logging esm config
access-list 1 permit any
access-list 100 permit ip 10.0.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password ______________-
 login
 transport input all
!
end

Open in new window


I tried just copy/pasting what you had written earlier, then i deleted Dialer1 and pasted what you had written, to see if that worked. neither worked. What debugging steps can i take to see where the issue lies?

I have this but it's not too helpful :
a#sh ppp interface dialer 1
PPP Serial Context Info
-------------------
Interface        : Di1
PPP Serial Handle: 0x0
PPP Handle       : 0x0
SSS Handle       : 0x0
AAA ID           : 0
Access IE        : 0x0
SHDB Handle      : 0x0
State            : Down
Last State       : Init
Last Event       : RestartTimeout

Open in new window

Author

Commented:
I got it working! I had to have it tagged with vlan 35 in order for it to work (a Bell Canada thing? )

for anyone else trying this in Canada, this is my working VDSL2 running config :
controller VDSL 0
!
bba-group pppoe global
!
interface Ethernet0
 no ip address
!
interface Ethernet0.35
 encapsulation dot1Q 35
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 shutdown
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 switchport access vlan 100
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.0.0.5 255.255.255.0
 ip flow ingress
 ip nat inside
 no ip virtual-reassembly in
 ip route-cache policy
 ip tcp adjust-mss 1452
!
interface Dialer1
 description VDSL teksavvy
 mtu 1492
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 no ip virtual-reassembly in
 encapsulation ppp
 ip route-cache policy
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username <username> password 0 <password>
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
!
logging esm config
access-list 1 permit any
access-list 100 permit ip 10.0.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!

Open in new window

Author

Commented:
Thanks for your help, You sent me in the right direction and was just what I needed..

love this community

Commented:
HI I have tried all combinations of this and cannot get this to work. the connection appears up but I cannot pass any traffic. This is my config to a Gamma FTTC connection

Trident#sh conf
Using 2836 out of 262136 bytes
!
! Last configuration change at 11:09:51 UTC Tue Aug 13 2013
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Trident
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 uzJrrnwXMsloKwNVbypEvzC3EaeTNBUiBSJWrpRTmW2
enable password stuart
!
no aaa new-model
memory-size iomem 10
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
multilink bundle-name authenticated
vpdn enable
!
license udi pid CISCO887VA-SEC-K9 sn xx
!
!
username xxxxx privilege 15 password 0 xxxx
!
!
!
!
!
controller VDSL 0
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
bba-group pppoe global
!
!
interface Ethernet0
 no ip address
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 switchport access vlan 100
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 bandwidth inherit
 ip address 192.168.2.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
!
interface Vlan100
 ip address 192.168.3.252 255.255.255.0
 ip flow ingress
 ip nat inside
 no ip virtual-reassembly in
 ip route-cache policy
 ip tcp adjust-mss 1452
!
interface Dialer1
 mtu 1492
 ip address 5.2.110.29 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 no ip virtual-reassembly in
 encapsulation ppp
 ip route-cache policy
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp chap hostname xxxxx
 ppp chap password 0 xxx
 ppp pap sent-username xxxxx pass xxxx
 ppp ipcp header-compression ack
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer1 overload
ip nat inside source route-map CRUSADER interface Dialer1 overload
!
ip access-list extended CRUSADER
 permit ip 192.168.2.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
route-map CRUSADER permit 1
 match ip address CRUSADER
!
snmp-server community xxxx RO
access-list 1 permit any
access-list 100 permit ip 192.168.3.0 0.0.0.255 any
!
control-plane
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0
 password xxxxx
 login
 transport input all
line vty 1 4
 password xxxxx
 login
 transport input all
!
!
end

Trident#

Commented:
I keep getting a 172.16.17.2 address is this problem at the provider. Chap authentication works fine and I get a successful login. but I cannot ping anything on the internet