Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1023
  • Last Modified:

How to change security permissions in Component Services

Recently I've come across some DistributedCOM errors on the event logs of a server:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{000C101C-0000-0000-C0000-000000000046}
and APPID
{000C101C-0000-0000-C0000-000000000046}


I've found the entry that this relates to in Component Services, but I am unable to change the security permissions, as the options are greyed out. After doing a little bit of research, I found that the Administrator account is not given full control of this entry. I have given the Administrator account full control of this entry, but am still unable to change the security permisions.

Is there something else that I'm missing here?

Thanks in advance :)
0
BCSOnline
Asked:
BCSOnline
  • 3
  • 2
1 Solution
 
footechCommented:
Can you provide the steps that you went through to give Administrator full control?  I'm assuming you took ownership of a registry key and then gave Administrators full control, correct?  Please provide the registry key you edited.
After you edit the permissions of the right key, relauch Component Services and dig down to the right AppID.  You should be able to select "Customize", then the "Edit" button to set the launch permissions.
0
 
BCSOnlineAuthor Commented:
Hi footech,

I've attached images from the Registry Editor, showing the entry that has been modified.

The steps that I took were as you mentioned. I took ownership of the key, and then gave Administrators full control. I've then gone to Component Services, found the AppID this relates to, and selected Properties, but all of the options are still greyed out. I've performed a reboot since changing the registry permissions, but he options are still greyed out.
RegistryEntry01.JPG
RegistryEntry02.JPG
0
 
footechCommented:
Unfortunately those screenshots don't give me the complete path.  But I think what you have there is from HCR\CLSID\{000C101C-0000-0000-C0000-000000000046}
Try changing HCR\AppID\{000C101C-0000-0000-C0000-000000000046}.  You want to change the permissions on the entire key (in the left panel).
0
 
BCSOnlineAuthor Commented:
Hi footech,

Turns out that changing the permissions on the AppID entry in the registry sorted it out. Sorry for not making it completely clear in the first place, but thanks very much for the help :)
0
 
footechCommented:
No problem, glad you got it working!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now