Terminal Server 2003 users need to set Outlook as default email client

We have a windows 2003 server running terminal services.
When users set Outlook 2003 as their default mail client (in Outlook's options dialog) it only works until they login again. Then it once again says there is no default mail client and they need to go into options and set it again.

What could be clearing the setting?
How do I get it to stay the default, permanently?

Windows Server 2003 does not have a "set program defaults" and the Folder Options File Types for mailto protocol have the "change" button grayed out.

Thank you
Who is Participating?
elidoranConnect With a Mentor Author Commented:
It sounds tougher to give them write permissions in the registry than just setting it for them. Your post prompted me to lookup the registry settings and I found this article:     http://support.microsoft.com/kb/933450

I created the reg file in that article and added their regedit command to the terminal users' logon script.
That seems to do the trick. Oh, I used "Microsoft Outlook" as the registry key. I determined that was the right one by setting Outlook as the default, then looking at the registry key.

It is setting itself to "Exchange" when we logon. I don't know why or what's doing that.
elidoranAuthor Commented:
Sorry, not the "change" button. Have to use "Advance" button. Can not create a new item in that list to use outlook because I can not locate outlook.exe to select it. It is not in c:\program files\microsoft office anywhere.
I have a working shortcut to it and that has an empty "start in" field and the target field is not the usual path to an exe, it is grayed out and says "Microsoft Office Professional Edition 2003".
Kruno DžoićSystem EngineerCommented:
By default, Windows Terminal Services clients do not have write access to the registry on the Windows Terminal Services computer, except to the registry hive under HKEY_CURRENT_USER. To run some Outlook features, you might need to give users write access to some keys and subkeys. For example, unlock the subkey HKEY_CLASSES_ROOT\CLSID to allow users to use the custom MAPI forms for Office Outlook 2007.
elidoranAuthor Commented:
Alright, found the outlook.exe, the previous admin installed it on both drives. Setting that in there doesn't work as desired. It opens the application instead of opening a "New message" window.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.