Cisco ASA 5505 IOS 8.4(2) VPN issues

It looks like Cisco changed the way that NAT is configured from the CLI from previous versions and I'm completely confused.  I have AnyConnect and Clientless SSL authenticating, but I'm 99% positive I have split-tunnel and NAT issues.  I even tried to use ASDM to set things up, but we won't discuss how much that hosed up the configuration.

I need the ability, from a remote location, to access the 192.168.0.0/24 network behind the 5505 without affecting any other routing.  Incoming AnyConnect clients get a 192.168.100.0/24 address.

It's a simple SOHO setup:  Cable modem - ASA - inside network with regular PC's and a Vonage device (which is why you'll see Vonage references.)  I've attached the config file, which has had the sensitive info removed.

If you can help, thanks!

Non-Working-Firewall.txt
gnurphAsked:
Who is Participating?
 
gnurphAuthor Commented:
I have found an alternative solution to the problem.
0
 
Robert Sutton JrSenior Network ManagerCommented:
Looks like your missing a few things:

Something like:
Object Network Vlan1
subnet 192.168.0.0 255.255.255.0         <=== Which you have in place

And add:

Object Network VPN
subnet 192.168.1.0 255.255.255.0

nat (inside,any) 1 source static VPN VPN destination static Vlan1 Vlan1

access-list DefaultWEBVPNGroup_splitTunnelAcl extended permit 192.168.1.0 255.255.255.0

Hope this helps.
0
 
Robert Sutton JrSenior Network ManagerCommented:
Oh, and remove the following:

access-list no_nat extended permit ip 192.168.101.0 255.255.255.0 any log disable
0
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

 
gnurphAuthor Commented:
The "access-list DefaultWEBVPNGroup_splitTunnelAcl" command required some modification, the ASA threw an error, so I made it:

access-list DefaultWEBVPNGroup_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any

I'll need to test it to see if that change works; Anyconnect won't let me RDP into another box to try it.
0
 
gnurphAuthor Commented:
No go.

A ping to 192.168.0.4 via AnyConnect fails.

The access-list you suggest - it isn't applied anywhere, is it?  just creating the access list doesn't do anything, I believe.
0
 
Robert Sutton JrSenior Network ManagerCommented:
What happens on your connection? Can you establish a connection and just can't get to local hosts?
Is it giving you an error? Please post it here if so...
0
 
Robert Sutton JrSenior Network ManagerCommented:
And are you configuring via CLI or asdm?
0
 
gnurphAuthor Commented:
CLI.  It connects, but unable to contact internal hosts on the 192.168.0.0/24 network.
0
 
Robert Sutton JrSenior Network ManagerCommented:
Please repost your current config so we can see what you have thus far and the changes that were made.  Thanks.
0
 
gnurphAuthor Commented:
Found alternative solution.
0
 
anttivaCommented:
Can you share your solution with us? I and many others are having similar problems and this could help a lot.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.