• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1907
  • Last Modified:

Exchange 2010 upgrade from 2003 - Mailbox Role

I feel like I must have missed a step in my upgrade from exchange 2003 to 2010.  I'm installing 2010 on  a new server and will be running in a a mixed\coesxistance mode while I move mailboxes from my old box to the new one.

So everything looks all good, I've got the hub, client access and mailbox roles on my new box.  If I open the EMC on the 2010 box, I can see the mailboxes on my older 2003 server.  I can't move them, and If I attempt to double click on a mailbox under recipient configuration I get:

"Couldn't find database DOLPHIN\First Storage Group\Mailbox Store (DOLPHIN) Make sure you have typed it correctly.  It was running the command get-Mailbox -identity 'foxshox.com/Users/Alexander'  -ReadFromDomainController"

Any ideas of what I missed?
0
JamesonJendreas
Asked:
JamesonJendreas
  • 13
  • 8
1 Solution
 
5g6tdcv4Commented:
What happens if you create a brand new user on the 2010 server?
0
 
JamesonJendreasAuthor Commented:
Adding a new account from the 2010 EMC completes without issue

One thing I notice, in my 2003 system manager, my old servers end up in their original Admin group, the new server is now in the newly created one.  From what I've read, it needs to stay in the newly created administrative group.

One other odd thing, if I even try to access the "Exchange Tasks" on my old 2003 box for a mailbox, it hangs a bit, then  I get the following error (and I assume this is the problem):

The RPC Server is unavailable

Facility: Win32
ID no: c00706ba
Microsoft Active Directory - Exchange Extension

0
 
JamesonJendreasAuthor Commented:
Looks like a WINS/DNS issue, but all my WINS/DNS info looks to be correct on my old 2003 system
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
5g6tdcv4Commented:
can you move a test user to the new server?
What does best practices analyzer report on the 2010 server?
0
 
JamesonJendreasAuthor Commented:
When I try to move a user, on the first step, under "Database" it says Object Not Found"

Interestingly, if I hit "browse" to view available target databases, I see 3 mailbox database - The new one, and store 2 and 3 from my old server.  I have 4 mailbox storage groups on my old server each with 3 or mailbox mailbox stores

I'll run best practices analyzer now (any specific test, baseline? connectivity?)
0
 
JamesonJendreasAuthor Commented:
For connectivity test, I do get:

Active Directory Server: 2003ADglobalCatalogServer.domain.com
Active Directory Server: WMI cannot be proccesed
Cannot connect to the Windows Managment Instrumentation repository on server 2003ADglobalCatalogServer.domain.com.  This could be a result of a network or permissions problem.  Error:Access is denied (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)


So looks like there is a security error. I ran the install for 2010 as the domain admin, as well as used the legacy permissions switch on setup.  Do I need to add my 2010 server to some specific AD group?
0
 
5g6tdcv4Commented:
Run the health check please as well
0
 
JamesonJendreasAuthor Commented:
Health check returned:
Offline address book not found (I believe this is because it's still on my old system)

Admin group FOXSHOX (my old group):
System pages set too high
Active Directory cannot be contacted <-- this!!!!
HapDeCommitFreeBlockThreshhold not set
open relay test failed
Physical memory configuration
Missing FQDN in service principle name

There are no errors for the new Admin group

One note, I did have a consultant who was tweaking my Active Directory over the past few days (and I was cringing the whole way).  I'm not seeming to have any other AD issues, but from what I'm seeing, the issue really look like there is some issue with communication with AD.  All my IP info (DNS, WINS) are pointed to my Domain Controllers.  I have 2 2003 DC's and 2 2008 DC's, with the  FSMO role assigned to a 2008 box.  All DC's are global catalogs.  We only have a single domain in our forest

0
 
JamesonJendreasAuthor Commented:
And on the permissions test. I get
Permissions inheritance block on Exchange database object
Access control List (ACL) inheritance is blocked for the exchange database object .......(Mailbox store info on old exchange 2003 server)


There are 18 of those.
0
 
JamesonJendreasAuthor Commented:
Process MSEXCHANGEADTOPOGYSERVICE.EXE (PID=1644).  All Domain Controller Servers in use are not responding:
[list of domain servers]


I can ping the domain servers w/o issue
0
 
5g6tdcv4Commented:
does "netdom query fsmo" return the correct server/servers?
0
 
5g6tdcv4Commented:
also in emc on the 2k10 server
1.Open Exchange management console
2.Right click on “organization configuration” or “server configuration”
3.Select “modify configuration domain controller”

specify a server that you know is operational
0
 
JamesonJendreasAuthor Commented:
Re: netdom query fsmo:
This is correct, it pulls my FSMO master for all roles correctly.

Both for Organization and Server Config, it's pointing to the right DC

0
 
5g6tdcv4Commented:
as a test point the exchange server to a 2k8 server
0
 
JamesonJendreasAuthor Commented:
The server it is pointed at is a 2008 server, the FSMO master is a server 2008 DC
0
 
JamesonJendreasAuthor Commented:
Also, in the 2010 EMC, i only see the local 2010 server as a mailbox server.  The 2003 server does not show as a mailbox server, but does show up under "Total Exchange 2003 Servers"
0
 
JamesonJendreasAuthor Commented:
Muhahahaha!  OK, I've made some progress!  I can now open 2003 mailbox properties from the 2010 EMC.

 Looks like it was a permissions issue.  I was logged into the 2010 as the domain admin.  What I did was open the Role Based Access Control User Editor from the EMC.  I logged in as the domain admin.  Next I added my domain account to the Organization management and server manager roles.

When I logged off as admin, and logged back on using my account, I was able to open the EMC and access mailboxes.


Now, I still have the RPC error when I try to preform exchange tasks on my 2003 box for the mailboxes that reside there.  
0
 
5g6tdcv4Commented:
Sweet nice evil laugh. :-)

You need to use the 2010 to manage mailboxes in coexistence mode
0
 
JamesonJendreasAuthor Commented:
Although I still get the :
Permissions inheritance block on Exchange database object
Access control List (ACL) inheritance is blocked for the exchange database object .......(Mailbox store info on old exchange 2003 server)
0
 
5g6tdcv4Commented:
There is a technet article regarding that
0
 
JamesonJendreasAuthor Commented:
yeah, I'm taking a look at that right now, I think we're moving it the right direction.  And I really appreciate all the assistance.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 13
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now