Webmin Webpage Does not display after initiating an OpenLDAP installation

mrmad1966
mrmad1966 used Ask the Experts™
on
Folks, I have a Ubuntu Server 10.04 LTS installed. It is currently a file server but I have decided I would now like to centralise my users and passwords as my windows 7 client PCs are incresing and the local users and passwords are now becoming a chore. I am following this guide https://help.ubuntu.com/10.04/serverguide/C/openldap-server.html.
I have ran the first command sudo apt-get install slapd ldap-utils and all seemed to go perfect but after a reboot I can login via putty but no longer through the web browser via webmin. I get a message to the effect of "the server rejected the connection"... Any ideas Gurus ?

Regards
John
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Maybe you need configure the webmin to load user authenticathion from ldap database.

More details: http://marc.info/?l=webmin-l&m=117433053615367

Author

Commented:
That article implies that they still can access there user min webpage. I cannot....
But you can try to edit the file "/etc/pam.d/usermin", no?
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
First problem while looking into this is I cannot ssh in using putty using the test user that was setup during the initial openLDAP installation, I do not appear to have a /etc/pam.d/ssh as in the article hyperlink, finally the /etc/pam.d/webmin file only has 4 simple include entries :-(
Still Stuck !
What are the entries in file (/etc/pam.d/webmin)?

Author

Commented:
Hi
Please see screenshot ! /etc/pam.d/webmin
Strange this file content... I expected something like this:

http://piiis.blogspot.com/2009/05/pamldap-authentication-for-webmin.html
Solved... The problem lay in the /etc/webmin/miniserv.conf file. I added the line allow=0.0.0.0 &hey presto, still no idea how it disappeared though !

Thanks for trying to help though !!

Author

Commented:
Unfortunately, earlier answers did not point to the file in question...Sorry

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial