Solved

Unable to get Windows Authentication to work in IIS7

Posted on 2011-09-02
9
495 Views
Last Modified: 2012-05-12
I have a site I need to have a login prompt appear.
I disabled Anonymous and enabled Windows like I used to do in IIS6.
But I get a 401 error on the page now saying I'm unauthorized.

How can I have the site prompt for the login?
Note: I want the user to enter domain credentials.

Thanks
Ron
0
Comment
Question by:Capt_Ron
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 2

Expert Comment

by:awarren85
ID: 36475519
IIS 7 has lots of differences and configuring WIndows Authentication is a pain as it isn't a "one-click" checkbox like it was in IIS 6.

This website has step-by-step instruction:
http://www.iis.net/ConfigReference/system.webServer/security/authentication/windowsAuthentication
0
 
LVL 1

Author Comment

by:Capt_Ron
ID: 36475719
Thanks.
I tried that and I still cannot get it to work.
There has to be something I'm missing.
0
 
LVL 2

Expert Comment

by:awarren85
ID: 36475738
What web browser are you using to view the site?

Also, if you go to IIS 7, click the Website name in the left column, go to Authentication, what do you have?  On mine here, all are disabled except for Windows Authentication.
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 1

Author Comment

by:Capt_Ron
ID: 36475752
IE9
Firefox

All are disabled except WIndows.
Provider is NTLM
Extended is Accept
Kernel-mode is unchecked
0
 
LVL 2

Expert Comment

by:awarren85
ID: 36475918
On mine at least, it's the following:

Kernel-Mode:  Checked
Extended:  Off
Provider (in this order):
    Negotiate
    NTLM

Maybe try mimicking these settings?
0
 
LVL 1

Author Comment

by:Capt_Ron
ID: 36475980
Nope.
Mimicked these and still no dice. :-(
0
 
LVL 2

Expert Comment

by:awarren85
ID: 36478645
Hrm, i'm stuck then.  Maybe check the event viewer on the server and see if you see domain errors?
0
 
LVL 1

Accepted Solution

by:
Capt_Ron earned 0 total points
ID: 37026331
Gave up.
Rebuilding servers from scratch.  Hoping something is wrong with these and new OS's will fix it.
0
 
LVL 1

Author Closing Comment

by:Capt_Ron
ID: 37052309
See note
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question