Windows 7 power management

Hello

I am working to tackle a huge issue for our campus. We are having trouble with Windows 7 computers going to sleep and not waking up.

Here are the details:

We use Dell Optiplex 755, 960, 980 and 990 computers across campus all running Windows 7. We use SCCM 2007 to deploy updates and Remote Desktop Gateway for RDP.

We have the BIOS configured:

Wake on Lan
Auto Wake Daily at 2:45-2:58am
Disable Low Power Mode
On the 990, we have disabled additional C states.

Inside Windows 7 we have set the Network card to "Allow this device to wake the computer" and we allow anything to wake it, not just a magic packet.

Despite these settings, the computers are not waking on lan for SCCM or Remote Desktop, and sometimes will not even wake up for the user at the desk and have to be power cycles. It is hindering our ability to deploy updates and manage computer labs.

What are we missing? We are looking at implementing Intel VPRO management.

We use onboard NICs, I have proposed doing a test using a PCI nic since it's my understanding the PCI bus can wake a computer that is fully powered off.

Could it be "hybrid sleep" preventing the onboard NIC from waking the PC?
TowsonStaffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gfilipeCommented:
Hi,

It seems to me probably the problem it not on the PC's but on the network.

If you are on a campus you should be using several diferent VLAN's that is probably why you are unable to use the WOL.
If it is a Cisco based network and probably Layer 3 switching you should make sure to use on each vlan interface the ip forward-broadcast;

To test if WOL is working on the machines simple add 2 machines with a cross-over cable and try to remote desktop one of them.

A simple but not ideal solution would be to disable the "Allow the computer to turn off this device to save power".

Regards,
Gfilipe
0
senadCommented:
In adapter properties uncheck 'allow computer to turn off this device to save power' .
0
johnb6767Commented:
"sometimes will not even wake up for the user at the desk and have to be power cycles"

This bothers me.... I am guessing you have your own custom image? I would remove/upgrade the Video Driver.....
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

rdudek101Commented:
gfilipe has it right.  First thing would be to test if it's a configuration within the systems.  So set 2 computers up with a crossover cable to try to wake them up with WOL.  Disable the "Allow computer to turn off this device to save power" option within the driver itself.  Also, try upgrading the BIOS as well in case there is an issue with the WOL function itself.  

If the crossover trick works, it means your network is not pushing in the broadcast and may need to verify the network configuration settings.  Without you letting us know what kind of a network it is, it's kind of hard to troubleshoot anything else.
0
TowsonStaffAuthor Commented:
We did BIOS upgrades as a first option since that seemeds logical; but it hasn't worked.

I know that we do use Cisco Network products, and we do use multiple Vlans, but I"m not sure about the Level 3 switching.

I will attempt to find out this information on Tuesday (Monday Holiday) and report back. I will also do the test with the crossover cable

Thank you for the replies so far.
0
TowsonStaffAuthor Commented:
Yes, we have our own custom image. Our desktop image is deployed via OSD and our lab images via Ghost.

I oversaw significant parts of the lab image creation, and I wrote a batch script to install the most recent video drivers from ATI. We do keep our video drivers up to date, but it certainly is worth considering as well.
0
TowsonStaffAuthor Commented:
The other thing I find interesting and I forgot to mention; the computers we have with XP don't seem to have this problem; it seems confined to Windows 7.
0
KezziCommented:
Make sure you disable hibernation completely and only use the standard power save.  If you are using SCCM R3 you can setup a power management policy for this.  

Also, once the win7 machine has gone into power save mode, the only way to wake it up again that I have found is via WOL.  I had managed to setup the NIC card to support this when RDP'ing to the machines by setting these settings on the advanced settings of the card:
Wait for Link = On
Wake on Link Settings = Forced
Wake on Magic Packet = Enabled
Wake on Pattern Match = Enabled

I then deploy my internal wake up timer via the SCCM power policy.

0
TowsonStaffAuthor Commented:
Hey

I found out some more information:

1.) We don't' use am SCCM Wake On Lan.

2.) We are a Cisco Layer 3 Routed network, but we have disabed IP-Forward across Vlans.

3.) Our nic's are configured to the correct wake on lan settings.

4.) We have not disabled Hybrid Sleep.



0
KezziCommented:
You do need to disable Hybrid Sleep.  WOL does not work when this is enabled.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TowsonStaffAuthor Commented:
We have disabled Hybrid Sleep, and are testing the other settings. Hope to see some success by the end of the week.
0
TowsonStaffAuthor Commented:
This was the key in solving this problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.