Remote Desktop Connection in Win7 - What is there is no login/pwd on the destination PC?

I'm using several Win 7 Pro/Ultimate PCs in my wireless LAN. I want to do remote desktop connectivity. The only thing I'm lacking is it is requesting the destination PC login/pwd, but there is none on any of my PCs and there is no advancing without one. I don't want to have to assign one just to be able to login.

Also, is it necessary to set up a static IP and if so, does it have to be done at the internal wireless adapter level or can I set it a static on the router?
Who is Participating?
johnb6767Connect With a Mentor Commented:
Are you sure?

Error Message: Unable to Log You on Because of an Account Restriction

I have never tested this, but have seen it come up before. Needless to say none of my personal machines have null passwords....
You must have passwords for login on all the computers.
You cant login with blank credentials.
Yep, you need a password.  If you want to keep your user account open (meaning no password), create another user account with a password and share your folders with the other user account.  This will allow you to remote in and access data.  Note a very secure thing to do though.

Another thing you can try is Logmein free service.  This will allow you to access it without a password.
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

On a LAN you can remote to a computer by computer name instead of an IP address so you don't need to set a static route. But if you would like to... you do it on the PC's not the router. Just know your range and set it to something that isn't being used. For instance if your IP range is to Use and work your way down for static IP's so they don't get assigned to a DHCP computer which will work thier way up from .100
Accounts: Limit local account use of blank passwords to console logon only

Try this. I do believe it applies to RDP.....
David Johnson, CD, MVPOwnerCommented:
no points:
All RDP usage requres a password on the account.
By Default, you can not RDP to machine without a user be a member of  either Local admin or Remote desktop Users. Also the account must have a password

I recommend you to use password at all cases, but I am assuming that you are running this in your HOME environment so you may not concern much about security.

to be able to RDP with the blank password as you wish:

First) the account that will be used through RDP should be a mamber of Administrators or Remote Desktop Users group on the remote machine

Second) In windows 7, The blank password is limited to console users only by DEFAULT. To disable that, type mmc on the (remote machine), then add/remove snap-in & then add "Group Policy Object Editor". Click Finish when it prompt with (Local computer)

This will open the group policy on your local machine.

In here, you will need navigate to Computer Configuration \ windows settings \ Security Settings \ Local Policies \ Security Options \ Accounts: Limit local account use of blank passwords to console logon only.

double click on "Accounts: Limit local account use of blank passwords to console logon only" and change the setting from "Enabled" to "Disabled"

you may need to go to command prompt and type "Gpupdate /force". This will upate the local policy with the new setting. It is also good to reboot your machine once as some policies can not be applied unless you reboot the machine

Third) Test your RDP with the account (member of: Administrators or Remote Desktop Users ) that hasd the blank password


Forgot to tell, that type MMC, you can do this by click Start and then type in the search box MMC and then press ENTER ( You should do this with an administrator account on the remote machine)

There is no need to repost the same information that we have already covered.....
I've requested that this question be deleted for the following reason:

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Accept http:#36476886

This is a documented policy.....
And just to confirm, I changed the local policy to disabled, and removed my password. It did allow an RDP connection to a Win7Ultimate PC....
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.