Solved

xp home msconfig only shows 11 services

Posted on 2011-09-02
8
433 Views
Last Modified: 2012-05-12
A coworker had  a very sick computer.  
I ran msconfigm turned on diagnostic mode, hid microsoft services, then turned off all other services.

Rebooted several times and tried various things that did not work.

I then booted into save mode (without networking) and on Windows installer service.

I used control panel to uninstall antivirus, windows defender and about 20 applications google earth, quick time, itunes etc etc.

I used msconfig to return mode to normal boot, and restarted.

Things go WAY faster, but something is still seriously wrong.


I can't get onto the internet in normal boot or in safe mode with networking. Msconfig in both safe mode and normal mode show only 9 services. In fact there is very little difference between the two modes.  


In BOTH modes, Msconfig only shows 9 services. And only microsoft services show, all others a totally missing.  computer management shows bunches of services disabled.  

ipconfig /renew says the rpc server is unavailable but that is one of the 9 services that IS started. << Remote Procedure Call (RPC) Locator is disabled and I can't enable it, but that service is not running on any of our working computers, so I don't think that is the issue.

And I cannot view any service dependancies.  The all seem to say they have not depencancies associated with them.  

I have tried rebuilding the WMI service by following instructions in http://windowsxp.mvps.org/repairwmi.htm.  (I skipped the step calling for comprehensive rebuild because it seemed a little drastic.  But, I might give that a try if nobody has a better idea

Rebuilding WMI helped some and now I have 15 services in msconfig, but msc services still shows bunches of important services disabled.  But I can now look at many of their dependancies.  Using that I was able to get RPC locator started, so now both RPC servers are running.  But ipconfig still says RPC SERVER is unavailable.

Does anybody have comprehensive list of the services that windows home xp needs to have enabled?  I could then enable each one manually.

I also tried these command lines which often work miracles, but still ipconfig says rpc is unavailable.

netsh int ip reset reset.log
netsh winsock reset catalog

SFC /scannow cannot be run because I do not have a CD for here computer and there is not c:\i386 folder.  Maybe the %windir%\Servicepacks\i386 folder?
I am running out of ideas.
0
Comment
Question by:rberke
8 Comments
 
LVL 1

Assisted Solution

by:leebrumbaugh
leebrumbaugh earned 100 total points
ID: 36476499
It sounds like you're a little out of luck.  You could try reinstalling Service Pack 3, but I'd imagine it'd ask you for the i386 folder.  If you found another computer with that on it you could copy it onto a cd to use against it.  I think SFC or a Service Pack is your best options by now.
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 36476501
It sounds like you have drivers missing too.  You're talking about manually installing Windows, piece by piece.  If you succeed, it will take a long time...  I would find another way to re-install Windows.
0
 
LVL 6

Expert Comment

by:c1nmo
ID: 36476504
IPv6 is ringing a bell for some reason, a quick search suggests

Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 5

Author Comment

by:rberke
ID: 36476509
modified registry sourcepath to point to c:\windows\servicepackfiles\i386  but scannow still insists on  CD.

I will call a few friends and see if they have a cd
0
 
LVL 5

Author Comment

by:rberke
ID: 36477547
I have a friend with Windows xp home sp3.

they have a c:\i386 folder which might help.

And, I have printed a list of the msc services  so I now know which services should be auto/disabled or manual and which are normally running.  

I will try fixing things over the weekend and see what happens
0
 
LVL 8

Accepted Solution

by:
JT92677 earned 400 total points
ID: 36481935
rberke -- the i386 on the original CD isn't the same one as the updates directory. You do need the original i386 to make changes, which is why you're being asked for it.

Copy the original i386 directory from an install CD to your hard disk somewhere, and
check the registry to be sure it also points there as well.  
Notice below that on my system it's on the D: drive, and I never
get asked for the original setup CD when making changes or updating.

In the REGISTRY:

Look for the "SourcePath" to see if it's pointing to where you have your i386 directory.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
...
"CSDVersion"="Service Pack 3, v.3300"
"CSDBuildNumber"="3300"
"SystemRoot"="C:\\WINDOWS"

"SourcePath"="D:\\I386"

"PathName"="C:\\WINDOWS"

This isn't the fix, but it's a step to avoid having your system keep asking for the original CD.

I hope it helps.

Jeff
0
 
LVL 5

Author Comment

by:rberke
ID: 36489761
You double slashes should have been single slashes.

I copied my friend's c:\i386 to the problem computer's c:\i386 and ran sfc /scannow. and change sourcepath to reference "c:\i386".

It still asked for the disk.  I then changed it to just c:\  and it still asked for the disk.  But when I said "Skip" it went ahead and scanned everything with no further messages.  This was a big improvement because earlier attempts (before the c:\i386 was created) gave me many repeated messages about needing the cd.  I am nearly certain the sfc got better because it now has the c:\i386 disk to get stuff from.

I also used msc services to change EVERY service to automatic, then rebooted.  I am now able to get onto the internet.  

I now want to restore the services to their "standard" settings  several dozen being manual and several dozen being disabled.  Going through each service one by one is a pain.  Does anybody know of a utility that allows me to select a dozen services at a time and switch them to manual?  I did a search and it looks like blackviper might do something like that, but I hope some expert can make a suggestion.

By the was, msconfig is now showing 20 startup processes which I think is about right.

0
 
LVL 5

Author Comment

by:rberke
ID: 36490911
http://www.blackviper.com/downloads/WinXP/Registry_Files/!Default_XP_Home_SP3_Start_v300.zip

contains a registry file that will restore xp home services to their default setting (e.g. automatic, manual, disabled)
I ran it and it worked well.

-------------------

http://www.blackviper.com/WinXP/registry.htm 

explains important steps to be taken first
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How does easy transfer work with Domain users? 2 117
Cannot log into several sites on one Windows 7  PC, Why? 32 163
no display on laptop 5 79
Exchange & AD management console 2 102
Most of the time we are in fix when all of sudden our systems behave weirdly.  Such problems cost time and effort... so it's best to take some preventive actions so that we can avoid such issues or overcome such problems more easily. Preventive M…
It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question