[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

Can't connect Blackberry to Excahnge 2007

Hi
We have an Exchange 2007 server and users use Blackberry to connect to the OWA site and get and received email.
Last week somebody has reset the router to factory default. I reconfigure everything and I make sure that port 80 and 443 are open.
Iphone and Windows phone connect no problem but non of the blackberry does.
We logon on the service provider and delete and recreate the corporate email but now we get an error saying that an error occur on the account verification process.
Not sure what is wrong but we can create any accounts on any other server except this one.
The URL for the OWA that I enter on the blackberry email setup work and the user name and password also work if use at https://domain.com/owa
https://domain.com/EWS/EXCHANGE.ASMX does not work on this server but work on the others. Nothing has change on teh server that I know but who knows if anybody else has touch the original config.
Any idea?
0
infedonetwork
Asked:
infedonetwork
1 Solution
 
Kent DyerCommented:
Don't know how much help I can provide as we use BES.  Within the Blackberry browser, have you tried to use Firefox, or Internet Explorer emulation?  Another option you can try with OWA is to download and install Opera and try to use that for connecting..

HTH,

Kent
0
 
infedonetworkAuthor Commented:
That's not how we do it.
We logon to the service provider site like www.fido.blackberry.com with  the user name and password then we click on add new email and we chose Exchange.
I have to enter the email adress then the user name and the OWA likw https://domain.com/owa and the mailbox name.
For some reason I get a message saying that there is an account verification error like you can see bellow
Capture.JPG
0
 
footechCommented:
Try entering the username in the form of DOMAIN\username.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
infedonetworkAuthor Commented:
I already did but did not work.
It use to work until thy rest the router to factory default.
After that it stop working. Port 80 and 443 is open
0
 
footechCommented:
I think you're going to want to keep using the username in that format during any other attempts.

It's much more likely that the problem is due to a configuration on the Exchange server rather then an issue related to the router.  With 80 and 443 correctly allowed through there's really nothing else on that front.

Is OWA set to use forms based authentication (FBA)?  Have any updates been applied to the Exchange recently?  What's the patch level of Exchange?
0
 
infedonetworkAuthor Commented:
It is Exchange Server 2007

Microsoft Corporation

Version: 08.01.0240.006

Don't know if any patch has been apply. I don't think so.
I'm not the IT on charge of this Excahnge Server. They have a diferent IT and he is on vacaion for now so I have to help until he come back.
Don't know much about what was done
0
 
infedonetworkAuthor Commented:
It use FBA with Name only enable FBA
0
 
footechCommented:
You say you have other Exchange 2007 servers that are working correctly.  I would compare these settings as in the screenshot above on the working vs. non-working Exchange.  But first thing I would try is enabling Basic Authentication.
0
 
infedonetworkAuthor Commented:
0
 
footechCommented:
In the cases I've seen, setting up Basic authentication has been the resolution (using SSL of course).  There was also an Exchange update that resolved a lot of issues (update rollup 9 if I remember correctly).  Also check the authentication settings on the EWS virtual directory.  Sorry, can't think of anything else and I don't have a system I can test.
0
 
mattclarifiedCommented:
you will need to configure the following ports on your firewall for the pop3 and IMAP traffic

IMAP4 - Forward ports 993 (Secure) and 143 to your Exchange server (not your edge server).
POP3 - Forward ports 995 (Secure) and 110.

Try these and see how you get on.

M@
0
 
footechCommented:
@ mattclarified -  maybe I should leave this question to the OP, but why would he need to open POP3 and IMAP4 to connect BIS to Exchange?  Unless you want to set up BIS so that it thinks it's just connecting to a plain old POP3 or IMAP4 account.  I've never needed to do this.
0
 
infedonetworkAuthor Commented:
Installing Exchange Rollup 10 fix the problem.
Not sure why it work for a while without then stop working but after I installed the update it work imediatly.
The Basic Authentication did not work without the update eider.
0
 
footechCommented:
Glad you got it working.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now