Solved

Log-in to SQL Server

Posted on 2011-09-02
8
472 Views
Last Modified: 2012-06-22
Last year, I installed SQL Server 2008R with pretty much the default settings so I can easily log-in and connect to database engine easily. I guess I used windows authentication to do so.
Lately, while SQL Server was open, I installed some iTune updates…, the open programs was forced closed in order to restart the laptop.
Now, when I try to connect to database engine, I get the following message:


TITLE: Connect to Server
------------------------------

Cannot connect to (local).

------------------------------
ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=2&LinkId=20476

------------------------------
BUTTONS:

OK

Apparently, I need to enter another another server name than the default "Local".

Question: Where can I find the server names in my computer? So that I could browse replace the "Local" option it gives as default?

Thank you.


------------------------------


SQL-Server-log-in.png
0
Comment
Question by:Mike Eghtebas
  • 4
  • 3
8 Comments
 
LVL 59

Expert Comment

by:Kevin Cross
ID: 36477097
Look under services. Check for the SQL Server service and see what is in the braces. MSSQLSERVER is the default instance and would be connected to as just the {system name}. If SQLEXPRESS or any other name is listed, that would mean you have a "named instance" and would be connected to by {machine name}\{instance name}.
0
 
LVL 3

Assisted Solution

by:John_Arifin
John_Arifin earned 50 total points
ID: 36477129
Have you checked that the server already run?
If it is, try to use .  (period) instead of (local) .
0
 
LVL 33

Author Comment

by:Mike Eghtebas
ID: 36479252
mwvisa1,

re> Look under services.

Where? How?

John_Arifin,

re:> ,,, server already run?

Was not running. I tried after the computer was booted up.  ans use of . instead of local didn't work.

Mike
0
 
LVL 59

Expert Comment

by:Kevin Cross
ID: 36479267
Look under services. Check for the SQL Server service and see what is in the braces. MSSQLSERVER is the default instance and would be connected to as just the {system name}. If SQLEXPRESS or any other name is listed, that would mean you have a "named instance" and would be connected to by {machine name}\{instance name}.

Open up Windows Services (Start > Run > Services.msc)
Look for the SQL Server service(s)
Next to SQL Server, you will see (MSSQLSERVER) or (INSTANCENAME).
Whatever is in the () will be the value you have to use while connecting to the sever as the INSTANCENAME unless it is MSSQLSERVER which represents default and as such does not need to be included.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 33

Author Comment

by:Mike Eghtebas
ID: 36479418
I have an image of "Services" included below. FYI, I am running Windows 7 professional.

For server name in "Connect to server" screen, I have replaced (Local) with the following but hasn't work so far:

SQLEXPRESS
MSSQLSERVER
MSSQL

I hope I don't have to re-install SQL Server again.

Thanks for the help.

Mike
0
 
LVL 33

Author Comment

by:Mike Eghtebas
ID: 36479420
I forgot to upload the image. Here it is:
LogginError.png
0
 
LVL 59

Accepted Solution

by:
Kevin Cross earned 450 total points
ID: 36479439
Okay. Look in the image you posted. The Name of the SQL service is "SQL Server (SQLEXPRESS)". That means that the instance name is SQLEXPRESS. Therefore, you need to connect as YourComputerName\SQLEXPRESS or .\SQLEXPRESS.
0
 
LVL 33

Author Comment

by:Mike Eghtebas
ID: 36479457
.\SQLEXPRESS

Works. I wonder why it had been replaced by (Local).

And also, this was suppose full version of 2008R not express.

One possibility is that after one year (student use) its setting changes from 2008R to 2008Express?

Thanks a lot.

Mike
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Suggested Solutions

In this article—a derivative of my DaytaBase.org blog post (http://daytabase.org/2011/06/18/what-week-is-it/)—I will explore a few different perspectives on which week today's date falls within using Microsoft SQL Server. First, to frame this stu…
Everyone has problem when going to load data into Data warehouse (EDW). They all need to confirm that data quality is good but they don't no how to proceed. Microsoft has provided new task within SSIS 2008 called "Data Profiler Task". It solve th…
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Using examples as well as descriptions, and references to Books Online, show the documentation available for datatypes, explain the available data types and show how data can be passed into and out of variables.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now