Solved

Exchange 2007 - oullook 2010/07- autodiscover internal users

Posted on 2011-09-02
4
588 Views
Last Modified: 2012-05-12

Would really appreciate any help on this.

This happened to one of our clients:
After installing outlook 2010 on internal workstations (running exchange 2007) I started getting the typical non matching certificate problem error. Been there, fixed after changing autodiscover internal URLs.

Now, on this particular case that didn't work. It was only after changing the external URLs that the certificate error stopped. Now how is that possible if these were internal domain users and not outlook anywhere clients.

Also, I found that outlook anywhere kept getting checked and the proxy settings were also being populated. Again, why would that happen with internal users.

It looks llike these users, for some reason were being treated as external users ??


The proxy settings problem happened also on another site, also running exchange 2007 but outlook 2007 in this case.  No certificate error (no clue why because I havent changed the URIs, maybe that error only shows up with outlook 2010??) but again the proxy settings were being filled.

Thanks so much for any help.
D.
0
Comment
Question by:reliantcorp
  • 2
4 Comments
 
LVL 5

Accepted Solution

by:
Feebleminder earned 500 total points
Comment Utility
This issue is one of annoyance and something that one of my clients wasn't utilizing, so was able to disable it. Here is a link to the topic with fix suggestions:

http://ilantz.wordpress.com/2009/06/18/prevent-outlook-anywhere-aka-rpc-over-http-from-being-automaticly-configured-in-exchange-2007-with-autodiscover/

Hope this works for you!
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
Comment Utility
AFAIK autodiscover brings up the urls.. if ur network connection is slow or some thing like that, instead of boing a rpc over tcp/ip , it does RPC over HTTPS. and it will start using external urls and it describes ur issue.

Make sure there is good connectivity and no network issues in ur org.

even  if u want u can try and remove EXPR using the following command

Get-outlookprovider –identity EXPR | remove-outlookprovider
after this recycle the application pool of AutoDiscover in IIS

but be informed that no Otlook anywhere clients will be able to automatically configure the profile, they can only do manually
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
Comment Utility
so u resolved ur issue by doing the following right  ??
remove EXPR using the following command

Get-outlookprovider –identity EXPR | remove-outlookprovider
after this recycle the application pool of AutoDiscover in IIS

reply is that was not what fixed the issue?
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now