Solved

VPS server running Server 2008 R2 doesn't map the terminal services remote printer port to the 'default' local printer

Posted on 2011-09-03
14
871 Views
Last Modified: 2012-05-12
We have installed the printer drivers for the printers on the server.
We have set the local printer to be accessible thru RDP so local printing can work.
We have used this same process on previous Windows server versions (Server 2003) and had no problem with the printer staying on the correct port.
We have tried with 'Print services' role installed; it removes the printers from the printer list, when the user logins in the next time.  We then need to re-add the printer and re-map it to the correct TSxxx port.
We have tried with 'Print services' role removed; the server remembers the printers, but it re-maps the printer to a different port each time the user logs in.  For example, the local printer port is WS1:PRN2, as referenced in the server, and it is mapped to TS001 (WS1:PRN2).  The next time the same user logs in, the printer still shows it is mapped to TS001 in the Control Panel, however, when the ports are looked at, the printer is now mapped to TS012 (WS:PRN2).  This requires the user to re-map the printer to the new port (TS012).

We have researched the blogs and done the steps required to resolve the issue without success.
Here is the latest blog that we referenced:
http://blogs.msdn.com/b/rds/archive/2007/05/03/introducing-terminal-services-easy-print-part-2.aspx

Any assistance and advise is greatly needed.

Thank you,
Evan
0
Comment
Question by:SwiftPoint
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
14 Comments
 
LVL 40

Expert Comment

by:footech
ID: 36479037
What is the goal you're trying to achieve?  You want the default printer on the client to still be the default printer when RDPing?  Printing is just not working?
0
 
LVL 1

Author Comment

by:SwiftPoint
ID: 36484681
The goal is to have the user RDP into the server and be able to print to the local default printer.

The server shows the printer as the default for the user, but the port mapping changes each time they login.  The server re-assigned the printer to a different TSxxx port.  The user has to go to the printer control panel, go to the 'printer properties', click on 'ports' and find the TSxxx port that maps to the local port, and select it before they can print on their local printer.

0
 
LVL 40

Expert Comment

by:footech
ID: 36489608
Well, not much of a solution here, but I can tell you that this is the behavior that I see on my servers and printing still works fine.  The first time I log on, my redirected printer will be attached to something like port TS001.  If I log off and then log back on, I will see the same redirected printer using port TS004.  If I look at TS001 it shows with a description of "Inactive TS port".  However, this doesn't cause me any problems.

I'm wondering if this could be more of an issue with drivers.
0
Why You Need a DevOps Toolchain

IT needs to deliver services with more agility and velocity. IT must roll out application features and innovations faster to keep up with customer demands, which is where a DevOps toolchain steps in. View the infographic to see why you need a DevOps toolchain.

 
LVL 1

Author Comment

by:SwiftPoint
ID: 36495034
Isn't RDP supposed to automatically track he porting?  I don't care what the port is, I just want the printer to print.  The server is remembering the last port that was set by the user, not remapping to the correct port, or keeping the local port mapped to the same (TSxxx) port.
0
 
LVL 40

Expert Comment

by:footech
ID: 36496669
Yes, RDP automatically creates these connections.  The redirected printer will use a port like "TSxxx (WorkstationName:PRN1)".  Each time you log on, for the same redirected printer, the TSxxx number might be different, but the (WorkstationName:PRN1) should stay the same.

Can you provide a screenshot of the ports tab before a change is made?
0
 
LVL 1

Author Comment

by:SwiftPoint
ID: 36540615
What you said is what is happening.  The WorkstationName:PRN1 is staying the same but I need to have the server know how to 'connect' it to the printer driver that it has.

On Windows XP, I have seen the 'Auto' feature, where the printer is automatically discovered and connected to the printer in the Control Panel.  I don't know how it 'reconnects' the printer to the driver, but it works.  

Is there a way to have it 'lock' the mapped port to a given TSxxx port?
Or have the printer in the control panel 'find' the printer connected to the remote workstation?

I need a solution, one way or the other.

Do I need to turn off the 'Easy print' feature?  I have followed the steps in the KB and still have the same behavior
http://technet.microsoft.com/en-us/library/cc753853%28WS.10%29.aspx



0
 
LVL 40

Expert Comment

by:footech
ID: 36546583
To answer a question:
>>>>>Is there a way to have it 'lock' the mapped port to a given TSxxx port?
No.

I'm having trouble picturing what you're describing.  I'd like to make sure that what you're seeing is the same as what I am and that I'm not missing something.  A screenshot (or several) would be helpful.

I'm not familiar with an "Auto" feature in XP.

Going back to the beginning, I also want to make sure I'm clear on your use of "mapping".  Again, the screenshot(s) would help.
0
 
LVL 1

Author Comment

by:SwiftPoint
ID: 36547138
I have attached two screen shots.  One shows the HP1200 printer is on port TS004, and in screenshot 2, you can see the remote workstation port 'Silverfox: PRN3 is currently 'mapped' to TS011.
When it was originally setup, TS004 mapped to Silverfox: PRN3.

I hope this clears up my meaning of 'mapping'.

Do you have any ideas how to get the printer in the control panel to stay mapped to the Silverfox: PRN3 port, without needing to go into the control panel everytime I login to change the port to the current one that maps or links to the 'Silverfox: PRN3'.

 how the port is mapped in this session the workstation port that should be selected
0
 
LVL 40

Accepted Solution

by:
footech earned 500 total points
ID: 36552650
OK, I think I see what is going on here.  In the screenshots above, the HP LaserJet is installed on the Remote Desktop Server.  I don't remember the options for the LJ 1200.  Where is this printer - is it local to the client, or to the RDS, or both?  Did you set it up as a network printer (printing over ethernet) or is it attached to the server via USB/parallel?  Either way, you shouldn't be editing the port that it uses.  Set it back to the original port it was on when you installed it.  If you don't remember, remove and reinstall.
The different scenarios:
Printer local to the server, not the client:
 - print directly to it, no reconfiguration needed.  The name you will print to will be "HP LaserJet 2100".  There is no redirection happening here.
Printer local to the client, not the server:
 - no need to install the printer on the RDS.  If possible use RD Easy Print, if not, just add the drivers without installing the printer on the RDS.  Printer should be installed on the client workstation.  Now, on the client, when you establish your RDP connection, make sure to choose "printers" under the local resources tab.  When you look at the printers on the RDS, the name you will print to will be "HP LaserJet 2100 (redirected x)", where "x" will be some number.  Redirection is occurring here.  If you look at the properties of this redirected printer, you will see that the ports are all grayed out, you won't be able to change them.  This is where the automatic mapping of the TSxxx port occurs.
Printer local to both:
 - Assuming that you have choosen "printers" under local resources when making your RDP connection, on the RDS under printers you will see both "HP LaserJet 2100" and "HP LaserJet 2100 (redirected x)".  In this case you could print to either one and it would work.

I think what you are going after is scenario 2.  If you've chosen to redirect the local printer when making the connection and you don't see a printer that says "(redirected x)" at the end of the name, then something else is happening.

Hope this helps.
0
 
LVL 1

Author Comment

by:SwiftPoint
ID: 36983746
My apologies.  The second scenario is what I have.  I have tried the previously mentioned solutions and they have not worked.  Thank you for your answers.
Apparently something else is happening; no matter if I enable or disable the 'Easy print' feature the printer is not being mapped correctly on subsequent logins.

I will delete the question within 24 hours.

Thank you for your assistance.
0
 
LVL 40

Expert Comment

by:footech
ID: 36987315
So a printer that says "redirected" is never visible when you logon to the RDS?

Are you getting any errors in the system event log?
0
 
LVL 1

Author Comment

by:SwiftPoint
ID: 37080145
None of the offered solutions worked.
Thanks for all your assistance.

0
 
LVL 1

Author Closing Comment

by:SwiftPoint
ID: 37080151
This did not resolve the issue.
We will continue to find solutions elsewhwere.
0

Featured Post

Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question