wrong national (Norwegian) characters when importing dbf files into MS SQL Server

Hi,

I have tried to buid an SSIS package importing dbf files into MS SQL server  database. I have problems with national characters. I use ADO Net data source with ODBC connector, I have defined DSN with uses Microsoft dbase driver. The resulting tables contain wrong charactes instead of national ones (Ø, Æ, Å). I have tried also FoxPro Ole DB driver. This one allows to force coding table ( which appears to be 1252) and results are correct, but it takes ages! to read files. I have also tried to read into MS Access 2010 database, errors are the same. The same errors when trying to open in excel.

I attach sample file.

PKPOLIKL.dbf.zip
kvilimasAsked:
Who is Participating?
 
als315Connect With a Mentor Commented:
By default there are OEM encoding ("DataCodePage"="OEM", you should change it to ANSI (for Access 2010):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Access Connectivity Engine\Engines\Xbase]
"DataCodePage"="ANSI"

0
 
kvilimasAuthor Commented:
Hi! Will this affect also how data are imported into sql server?
0
 
als315Commented:
I've never tried to import DBF files directly to SQL, you can try.
If you link or import file to Access and then import from Access to SQL, all will be OK.
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
als315Commented:
Before Access 2007 this parameter  was in Jet path of registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase]
"DataCodePage"="ANSI"
May be it will work for SQL.
You can try to search in registry "Xbase" and "DataCodePage". By default there is "OEM"
0
 
BbaseCommented:
Thank you for sharing this usefull information. One remark: changing "DataCodePage" to "ANSI" solves the problem for opening DBF files in Access 2010. Not in Excel 2010.

Is there a similar registry setting for Excel?
Many thanks.
Bbase
0
 
als315Commented:
Sorry Bbase, as I know Excel can work only with OEM DBFs.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.