Solved

sbs2003 can't ping gateway

Posted on 2011-09-03
32
876 Views
Last Modified: 2012-05-12
I am having network access problems and was hoping someone could help me out.  

Our network consists of an sbs 2003 (non-premium) acting as DC for around 25 clients (all XP except two Windows 7) and another server acting as a file server.  The DC also runs DNS and DHCP.  A cable modem supplies Internet access through a Bountiful BWRG-1000 router/gateway.

We had a power outage and after restarting the DC, neither it nor the clients could access the Internet or any of the shared drives on the file server.  None of the clients or the DC can ping the router (the clients and DC give a request timed out error; the other server says "Destination host unreachable.").  None of the clients can ping the DC or other clients, either.

The servers and clients can ping their own IP addresses as well as 127.0.0.1.

The servers and clients access the router through unmanaged switches.  I've changed cat5 cables, changed ports on the switches, and power-cycled the switches and router with no effect.  I've also rebooted the DC several times with no effect.

One wrinkle is that I can connect the DC to one of the LAN ports on the router and get to the Internet (which is how I'm typing this).  I don't think the switches are bad (all the activity lights look normal), but is there an easy way to tell just in case?

Can anyone start me in the right direction?  I've browsed this site and Google for a couple of hours with no success.  Thanks!
0
Comment
Question by:rcw13
  • 16
  • 10
  • 5
  • +1
32 Comments
 
LVL 5

Expert Comment

by:Feebleminder
ID: 36479366
Post an ipconfig /all of your DC. Also have you logged into the router to ensure that it didn't reset it configurations?

Check to make sure that the DNS/DHCP is enabled and has no errors(check the logs).

Post your findings
0
 

Author Comment

by:rcw13
ID: 36479398
Here's the ipconfig /all from the DC:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : sbs01
   Primary Dns Suffix  . . . . . . . : ModernBenefitsInc.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ModernBenefitsInc.local

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-14-22-77-53-7B
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.2

I have checked (and double checked) the router settings and they are the same as before the outage.

Nothing obviously wrong in the DNS log.  But there looks like some random stopping and starting in the DHCP log:

25,09/03/11,15:15:59,0 leases expired and 0 leases deleted,,,,
25,09/03/11,15:15:59,0 leases expired and 0 leases deleted,,,,
11,09/03/11,15:35:48,Renew,192.168.1.110,KC-08.,00265AC245A7,
11,09/03/11,15:55:30,Renew,192.168.1.109,KC-17-JOHNNY.ModernBenefitsInc.local,F04DA2F89175,
11,09/03/11,15:55:48,Renew,192.168.1.106,owner-60558583a.ModernBenefitsInc.local,001D09908511,
11,09/03/11,15:57:30,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
01,09/03/11,16:05:19,Stopped,,,,
00,09/03/11,16:23:13,Started,,,,
55,09/03/11,16:23:19,Authorized(servicing),,,,
01,09/03/11,16:43:51,Stopped,,,,
00,09/03/11,16:59:32,Started,,,,
55,09/03/11,16:59:38,Authorized(servicing),,,,
01,09/03/11,17:30:02,Stopped,,,,
00,09/03/11,17:30:40,Started,,,,
55,09/03/11,17:30:46,Authorized(servicing),,,,
11,09/03/11,17:31:25,Renew,192.168.1.110,KC-08.,00265AC245A7,
11,09/03/11,17:31:30,Renew,192.168.1.110,KC-08.,00265AC245A7,
11,09/03/11,17:39:35,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
11,09/03/11,17:48:18,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
11,09/03/11,17:48:32,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
11,09/03/11,17:54:37,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
01,09/03/11,17:57:01,Stopped,,,,
00,09/03/11,18:02:29,Started,,,,
55,09/03/11,18:02:35,Authorized(servicing),,,,
01,09/03/11,18:07:49,Stopped,,,,
00,09/03/11,18:07:55,Started,,,,
55,09/03/11,18:08:01,Authorized(servicing),,,,
01,09/03/11,18:15:03,Stopped,,,,
00,09/03/11,18:27:34,Started,,,,
55,09/03/11,18:27:40,Authorized(servicing),,,,
11,09/03/11,18:29:58,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
11,09/03/11,19:10:13,Renew,192.168.1.117,Bobs-iPhone,00264A36CBCF,
24,09/03/11,19:27:34,Database Cleanup Begin,,,,
25,09/03/11,19:27:34,0 leases expired and 0 leases deleted,,,,
25,09/03/11,19:27:34,0 leases expired and 0 leases deleted,,,,
01,09/03/11,20:11:06,Stopped,,,,
00,09/03/11,20:16:47,Started,,,,
55,09/03/11,20:16:53,Authorized(servicing),,,,
0
 
LVL 5

Expert Comment

by:Feebleminder
ID: 36479404
What kind of error(s), if any are you getting in the system event viewer log?
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479411
Have you tried re-running the (CEICW) The Configure E-mail and Internet Connection Wizard ?
0
 

Author Comment

by:rcw13
ID: 36479428
There are some DNS registration/deletion errors (events 5774 and 5775).  Time errors (event 17).  Nothing else out of the usual.
0
 

Author Comment

by:rcw13
ID: 36479443
@mikeewalton - yes, I've run the CEICW twice.
0
 
LVL 5

Expert Comment

by:Feebleminder
ID: 36479450
Restart these services on the server:

DHCP Service
DNS Service
Netlogon Service

Can you post information I've mentioned above about a workstation? Event viewer log errors, ipconfig /all, nslookup (from server also)

Thanks
0
 
LVL 5

Expert Comment

by:Feebleminder
ID: 36479452
Oh and check the logs after each service.... Let's try to narrow down the your connection problem
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479458
*Not a fix, just for troubleshooting*

What happends if you take a workstation and manual set the ip to

IP:192.168.1.x
SUB:255.255.255.0
Gateway:192.168.1.1

D.N.S. (public) 8.8.8.8

Can it then access internet? Or not?
0
 

Author Comment

by:rcw13
ID: 36479496
nslookup from server:
Default Server:  sbs01.modernbenefitsinc.local
Address:  192.168.1.2

nslookup from client:
DNS request timed out
     timeout was 2 seconds
****Can't find server name for address 192.168.1.2. Timed out.
****Default servers are not available
Default server: UnKnown
Address: 192.168.1.2

Windows Ip configuration
Host Name.............: OFFICE4
Primary DNS suffix....: ModernBenefitsInc.local
Node type.............: Hybrid
Ip Routing Enabled....: No
WINS Proxy Enabled....: No
DNS Suffix Search List: ModernBenefitsInc.local
                       ModernBenefitsInc.local


Ethernet adapter Local Area Connection:
Connection Specific DNS suffix: ModernBenefitsInc.local
Description...................: Intel (R) 82562V-2 10/100 Network Connection
Physical Address..............: 00-21-9B-00-17-32
DHCP enabled..................: Yes
Autoconfiguration enabled.....: Yes
IP Address....................: 192.168.1.100
Subnet Mask...................: 255.255.255.0
Default Gateway...............: 192.168.1.1
DHCP Server...................: 192.168.1.2
DNS Server....................: 192.168.1.2
Primary WINS Server...........: 192.168.1.2
Lease obtained................: Saturday, September 3, 2011 8:37:58
Lease expires.................: Sunday, September 11, 2011 8:37:58

Will post results from logs next and try mikeewalton's suggestion on the workstation.
0
 

Author Comment

by:rcw13
ID: 36479499
Nothing in the DNS and DHCP logs after restarting those services.
0
 

Author Comment

by:rcw13
ID: 36479514
@mikeewalton -- The workstation cannot access the Internet with those settings.

Event Ids in the workstation event viewer include 7 (Kerberos), 5719 (Net Logon), 29 and 14 (W32 TIme) -- several instances of each.  One instance of 8003 (MrxSMB).
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479526
Then we need to look at the network layer (i.e. switch, router, etc) instead of anything with the SBS.  Although that has me curious how you got the SBS to access out.
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479533
What kind of switches are these? How many?
0
 

Author Comment

by:rcw13
ID: 36479543
Netgear ProSafe 24 port and 16 port
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479550
I'm not sure of the architecture of your site and how easy this will be, but you currently have the DC plugged into one of the router port in which you are getting access. So we know that's a good port and all. Try taking one of the switches and plugging them into this port, and then the DC into that switch. Test for access. If no, try the other switch.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:rcw13
ID: 36479552
The DC was connected through the 24 port.  When I bypass that switch and connect the SBS directly through the router, the SBS can access the Internet.  But like I said, both switches appear to be working correctly.
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479558
Do you by chance have another switch lying around we can test with.  It appears as either there is an issue with those switches, or something has changed in the gateway and started blocking traffic originating from those switches.
0
 

Author Comment

by:rcw13
ID: 36479573
The only other switch I have on hand is a dinky little 4 port D-Link switch.  I can actually get to the Internet using that swith: router-switch-SBS.
0
 
LVL 5

Expert Comment

by:Feebleminder
ID: 36479582
just for testing... connect a cable from the 4-port to the main switch and see if any workstation will communicate.
0
 

Author Comment

by:rcw13
ID: 36479599
I tried a couple workstations, but neither would communicate.
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36479603
What are the model #'s on them switches?
0
 

Author Comment

by:rcw13
ID: 36479615
JFS524 and FS116
0
 
LVL 7

Accepted Solution

by:
mikeewalton earned 500 total points
ID: 36479638
Just from a little research I can see that these appear to be very problematic switches, from power issues, to weird network issues, etc. Since these are pretty much "throw away" switches, I think I would source a couple of locally un-managed switches to get by, then order a couple of good layer 3 managed switches for permanent installation.....As per our testing it definitely appears that we have traced the issue to the switches. Unfortatnately with these being unmanaged switches besides rebooting them, theres not much more we can do with them.

Just to be sure (I expect the same results) you might try moving one of those switches to another port on the router, i.e. one of the ports you are for sure getting access on.

It is also possible that they are not auto negotiating, so you could try a cross over cable, but I'm pretty sure they're just gone.
0
 

Author Comment

by:rcw13
ID: 36479653
I'm going to sign off for now and come back to it in the morning.  Looks like I will be going shopping tomorrow to find some new switches.  I will also keep in mind your suggestion of managed swiches.  Thanks for your help!
0
 
LVL 2

Expert Comment

by:atea_bjorn
ID: 36480242
It really sounds like you have a faulty switch here. So try get a new switch to try with. Start by trying to connect the workstations to each other first. And then try the internet.

Cheers
Björn
0
 

Author Comment

by:rcw13
ID: 36481804
Hi guys.  I've installed new switches (temporary, until I can get some good managed switches) and am making progress.  Using a new 24 port switch, the DC and the clients connected to it have access to the Internet and can ping each other.  The workstations can pull IP addresses from the DC.

Part of the problem I eventually discovered is that the other server (file server) had a wonky NIC that worked just enough to fool me that it was OK.  Since I was doing some testing of the network connectivity from that server, it gave a false indication of the state of the network.  I've installed a new NIC and initially it worked great -- it could access the Internet and the workstations could access the shared folders.  After about 15 minutes, however, it can only intermittently ping the gateway and connect to the Internet.  The DC and workstations can sometimes (but not always, say one out of 4 times) ping the file server.

Here's the kicker though -- attempting to patch the other new switch (16 port) into the network throws everything off.  At first I thought maybe it was a bad cable or rogue switch port, but it's not.  With that second switch cabled into the network, neither server can access the gateway reliably and neither can the clients -- the original problem.  When I ping the gateway from the DC maybe 1 or 2 of the packets succeed. From the other server, all result in "Request timed out."  The workstations likewise can't access the Internet when the second switch is involved.

Any ideas on what may be going on with the second switch or the file server?
0
 

Author Comment

by:rcw13
ID: 36481824
I should add that the new switches are D-Link, DES-1024D and Dss-16+
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36481844
a.) What happens with just the 2nd switch uplinked in? Nothing plugged into the 2nd switch.

b.) If fine, what is plugged into that 2nd switch. Start plugging devices in until it throws the network again.

c.) Due to the earlier issue you found with that file server, might want to leave it unplugged until you get the network acting right, then patch it in. Just to be sure it's not causing anymore issues.
0
 

Author Comment

by:rcw13
ID: 36482013
a) Everything seems OK with just the 2nd switch uplinked.

b) I think I found the offending cable.  I'm tryng to track down which device it's plugged into.  It's not obvious because everything comes in through a patch panel.

c) Without that particular cable plugged into the 2nd switch, everything seems OK.  I've patched the other server back in, and the workstations can find the shared folders.  The server can also access the Internet.
0
 
LVL 7

Expert Comment

by:mikeewalton
ID: 36482023
Excellent, keep me updated on what device you find it to be.
0
 

Author Closing Comment

by:rcw13
ID: 36532078
One of the switches was indeed faulty.  I replaced them both (just to be safe) with the result that the network is functioning normally now.  Thanks!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

A lot of problems and solutions are available on the net for the error message "Source server does not meet minimum requirements for migration" while performing a migration from Small Business Server 2003 to SBS 2008. This error pops up just before …
I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now