Solved

Cisco Port security

Posted on 2011-09-04
15
278 Views
Last Modified: 2012-05-12
Need to know why or how statement:

"Switchport port-security violation restrict"

is propagating to my other switches. I HAVE NEVER seen port security on one switch violate  or span to other switches. I have a phone, Cisco 7961, that would not register within VTP domain becuase it was sticky-mac'd on another switch. When I removed the statement from the other switch it did in fact start to register. I do NOT control Call Manager at my shop, and seriously feel that the techs who do are misleading me. Could this be the case?

P.S.- I DID in fact give them all the correct information beforehand. i.e, did a:

"s cdp neigh g1/0/10 d" to report what the switch has learned on that port.

Thx
0
Comment
Question by:michael_s_taylor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 125 total points
ID: 36480258
>is propagating to my other switches.

Port security does not propagate.

>I HAVE NEVER seen port security on one switch violate  or span to other switches.

You are correct. It doesn't.

>I have a phone, Cisco 7961, that would not register within VTP domain becuase it was sticky-mac'd on another switch

I'm guessing that you don't mean VTP (VLAN Trunking Protocol) but maybe SIP, SCCP or maybe even CDP. But this is possible. If your phone's MAC address is configured to a port that can't be used to reach your phone then it would be difficult to create a bi-directional session.

0
 

Author Comment

by:michael_s_taylor
ID: 36480370
So this interpretation is correct. Port security does not propagate. I have taken over a network with only 12 switches. from a 500 switch network. I wanted to make sure I wasn't going crazy...

Thank you
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 36480576
Nope. You're sane. ;-)
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:michael_s_taylor
ID: 37272540
Ok. I am listing my config with the exception of VTP/IP information for security reasons. this is to my core switch please help me find out WHY port security information is propagating to my other switches and denying access to devices. To be more specific, the devices that I connect to ANOTHER switch DO NOT trip port security but aren't allowed connectivity until I clear their respective MAC from the other switch.

Thx

Current configuration : 24632 bytes
!

!
version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname
!
boot-start-marker
boot-end-marker
!
logging buffered 10000
logging rate-limit all 1
no logging console
enable
!
username
!
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login vty-in group tacacs+ local
aaa authorization exec default group tacacs+ local
aaa accounting send stop-record authentication failure
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 1 cmds1 start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting commands 15 cmds15 start-stop group tacacs+
aaa accounting network default stop-only group tacacs+
!
!
!
aaa session-id common
system mtu routing 1500
no ip source-route
ip routing
no ip domain-lookup
ip domain-name mmcs.army.mil
ip name-server
ip name-server
ip name-server
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
!
ip dhcp pool VoIP
   network
   
!
login block-for 100 attempts 5 within 100
login on-failure log every 3
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto key
!
!
memory free low-watermark processor 20
memory free low-watermark IO 20
!
mac access-list extended
 permit host 0015.c5c0.5119 any
 permit host 0024.e810.cbbe any
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,10,20,30,40,50-51,100 priority 0
spanning-tree vlan 55 priority 4096
spanning-tree vlan 80 priority 24576
!
vlan internal allocation policy ascending
!
ip tftp source-interface Vlan30
ip ssh time-out 60
ip ssh version 2
!
class-map match-any VOIP_RTP
 match ip dscp ef
class-map match-any VOIP_Control
 match ip dscp cs3
!
!
policy-map VLAN10
 class VOIP_RTP
  set dscp af42
 class VOIP_Control
  set dscp af32
!
!
!
!
interface GigabitEthernet0/1
 
 mls qos trust dscp
!
interface GigabitEthernet0/2
 
 switchport access vlan 80
 speed 100
 duplex full
!
interface GigabitEthernet0/3

 switchport access vlan 30
 switchport mode access
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description
 switchport access vlan 20
 switchport mode access
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/5
 description
 switchport access vlan 20
 switchport mode access
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/6
 description
 switchport access vlan 20
 switchport mode access
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/7
 description
 switchport access vlan 20
 switchport mode access
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/17
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/18
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/19
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/20
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/21
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/22
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/23
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/24
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/25
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/26
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/27
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/28
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/29
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/30
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/31
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/32
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/33
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/34
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/35
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/36
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/37
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/38
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/39
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/40
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/41
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/42
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/43
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/44
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/45
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/46
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/47
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/48
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 10
 mls qos trust device cisco-phone
 mls qos vlan-based
 spanning-tree portfast
!
interface GigabitEthernet0/49
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/50
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/51
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface GigabitEthernet0/52
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust dscp
!
interface Vlan1
 
 ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan10
 
 ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 service-policy input VLAN10
!
interface Vlan20
 
 ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
!
interface Vlan30
 
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
!
interface Vlan40
 
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
!
interface Vlan50
 
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan80
 
interface Vlan100
 
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
!
!
router eigrp 81
 
ip default-gateway
ip classless

no ip http server
ip http access-class 3
ip http authentication aaa login-authentication vty-in
ip http secure-server
!
ip tacacs source-interface Vlan30
!
!
ip sla enable reaction-alerts
logging source-interface Vlan30

access-list 1 remark
access-list 1 permit 155.19.219.3
access-list 1 permit 155.19.219.5
access-list 1 permit 155.19.219.4
access-list 1 permit 155.19.219.8
access-list 1 remark CiscoWorks
access-list 1 permit
access-list 1 remark SNMP Servers allowed to connect
access-list 1 permit 0
access-list 1 remark MRTG Poller
access-list 1 permit
access-list 1 deny   any log
access-list 2 remark tftp servers allowed to connect
access-list 2 permit  log
access-list 2 deny   any log
access-list 3 remark device web service access
access-list 3 permit 0 log
access-list 3 deny   any log
!

snmp-server trap-source Vlan30
snmp-server tftp-server-list 2
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps cluster
snmp-server enable traps entity
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps syslog
snmp-server enable traps rtr
snmp-server enable traps mac-notification change move threshold

snmp-server file-transfer access-group 2 protocol tftp
snmp ifmib ifindex persist
tacacs-server host  timeout 5
tacacs-server host  timeout 5
no tacacs-server directed-request
tacacs-server key
!

default-value exec-character-bits 8
!
line con 0
 exec-timeout 9 0
 accounting commands 1 cmds1
 accounting commands 15 cmds15
 logging synchronous
 login authentication vty-in
 transport output ssh
line vty 0 4
 exec-timeout 9 0
 accounting commands 1 cmds1
 accounting commands 15 cmds15
 logging synchronous
 login authentication vty-in
 transport input ssh
 transport output all
line vty 5 15
 exec-timeout 9 0
 accounting commands 1 cmds1
 accounting commands 15 cmds15
 login authentication vty-in
 transport input ssh
 transport output none
!
ntp authentication-key
ntp authenticate
ntp trusted-key 123
ntp clock-period 36028899
ntp source Vlan30
ntp server
end
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37272598
WHY port security information is propagating to my other switches and denying access to devices.
First, it isn't. Because it can't.

Second, you don't have port-security enabled.

Third, if you're going to post a long config, please use the "code" feature when you post it.



0
 

Author Comment

by:michael_s_taylor
ID: 37272806
I understand that port security is NOT enabled ON this switch ( My Opologies). My question is when it is enabled I DO have to clear it on the previous switch. I just took over this network and I am noticing this behaviour. I have NEVER seen this before and can't figure out the solution...just picture the config provided WITH port security enabled I.e,, the following:

Switchport port security
Switchport port security mac sticky

a very basic one and I am not able to attach an existing device to another switch on the same VTP domain that has NOT learned this MAC from ANY port on it. When I do it MUST be cleared off of the prior switch before it receives service or DHCP for that matter
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37272822
This phraseology isn't working.

You have two switches: S1 and S2. The fa0/1 port on S1 connects to the fa0/1 port on S2. PC1 is connected to port f0/2 on S2.

On which switch and port is port-security enabled?
0
 

Author Comment

by:michael_s_taylor
ID: 37272993
Ok S1 and S2 are connected via a  802.1q trunk. lets say that i have sticky mac enabled accross all access ports on S1 and I have a PC that has been attached to S1, Port1 and it has learned its MAC. When I proceed to move it to S2 port 1 with Port Security Sticky mac enabled on that device, it DOES NOT shutdown ( Which it shouldn't anyway) however, it does not:

A.) get a mac address
b.) get services, obviously

Enigma???
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37273417
> A.) get a mac address

You mean that S2 doesn't get an entry for the PC in it's MAC address table?

>b.) get services, obviously

I don't follow.

When the PC was connected to S1, what there an entry in the MAC address table for the PC on S1 and S2?
0
 

Author Comment

by:michael_s_taylor
ID: 37273702
I'm sorry I was on the phone when I was writing this and I was distracted I meant "IP address" and NOT MAC address. But yes to answer your question  when I check the CAM it is listed on S2 but for some reason it is denied access and does not get a lease when it is connected to S2. And YES the CAM did distribute that MAC accross both switches when I do a s mac addr | i xxxx. So, my question still remains is there some statement I'm not applying that keeps port security local to the switch that a device is on? Or is, by some unknown force, VTP is propagating port security information to other switches via 802.1q. The last network I came from had the very same setup with 802.1q tagging but had 600 switches. Can you believe my heartache if this were to happen there?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37273915
So there's a DHCP server? Where is that located?
0
 

Author Comment

by:michael_s_taylor
ID: 37273941
I took it out of the config. but it resided on vlan 50. I had it pointing to a windows server. Ip-helper xxxx.xxxx.xxxx.xxxx
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37273951
Where is the DHCP server located? S1 or S2?
0
 

Author Comment

by:michael_s_taylor
ID: 37277451
It is going to a windows 2008 box. But I think we are missing the real issue. Even if it were statically assigned I would not be able to get access until I cleared Port security off of the oringinating device
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 37278712
One thing at a time please. Which switch is the DHCP server connected to?
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question